Dana L Beatty commented on May 10, 2010

Install the new and improved IBM Software Support Toolbar for easy access to key support resources!

I get the following error "IBM Software Support Toolbar 3.3.8 could not be installed because it is not compatible with Firefox 3.6.3"