Skip to main content
This forum is closed to new posts and responses. New discussions are now taking place in the IBM Developer Answers forum.
 
developerWorks
AIX and UNIX
Information Mgmt
Lotus
New to Lotus
Products
How to buy
Downloads
Live demos
Technical library
Training
Support
Forums & community
Events
Rational
Tivoli
WebSphere
Java™ technology
Linux
Open source
SOA and Web services
Web development
XML
My developerWorks
About dW
Submit content
Feedback



developerWorks  >  Lotus  >  Forums & community  >  Notes/Domino 6 and 7 Forum

Notes/Domino 6 and 7 Forum

developerWorks

  

PreviousPrevious NextNext


Abhishek SenGupta 5.Jun.13 03:10 AM a Web browser
Applications Development All Releases Windows XP


Hi,

We have a strange problem in one of our Lotus Notes 5 applications in browser.

This application has a configuration document storing application related data and can be accessed from config view. This config document can be opened from a link within application menu in browser. Code to open the link is here below...

function AbrirAdmin(){
if(JSAdmin=="N"){
window.location=window.location.protocol+"//"+window.location.hostname+'/'+JSPath+'/fconfig?OpenForm';
}else{
window.location=window.location.protocol+"//"+window.location.hostname+'/'+JSPath+'/vwConfig/'+JSIDAdmin+'?OpenDocument';
}
}

While JSAdmin, JSIDAdmin and JSPath values are here below declared on the form with computed texts...

JSAdmin:
x:=@DbLookup("":"NoCache" ;"";"vconfig";"CONFIG";"cnf_clave");
@If(@IsError(x) | x="";"N";"S")

JSIDAdmin:
x:=@DbColumn("":"NoCache" ;"";"(Configuracion)";"");
@If(@IsError(x) | x="";"";x)

JSPath:
@ReplaceSubstring(@Subset(@DbName; -1); "\\"; "/")

We have Config document stored in application, and all fields referred here have proper values within the document.

But problem is while an user clicks on the link to open configuration document, it opens a new document with fconfig form. So by code it can be said that JSAdmin value gets calculated as 'N'.

To bypass that we have removed conditional opening of document and directly put this code below...

window.location=window.location.protocol+"//"+window.location.hostname+'/'+JSPath+'/vwConfig/'+JSIDAdmin+'?OpenDocument';

But this opens a page with page cannot be displayed message. Further we have deleted this config document from our test server, copied and pasted one from dev server, changed values accordingly and that has been failed too.

This same code runs well in our dev and prod environment, while fails in test.

Please help us to resolve this issue.

Thanks in anticipation.

Regards,

Abhishek SenGupta.








  Document options
Print this pagePrint this page

 Search this forum

  Forum views and search
Date (threaded)
Date (flat)
With excerpt
Author
Category
Platform
Release
Advanced search

 RSS feedsRSS
All forum posts RSS
All main topics RSS
More Lotus RSS feeds

Resources

 Resources
Forum use and etiquette
Native Notes Access
Web site Feedback

Lotus Support

 Lotus Support
IBM Support Portal - Lotus software
Lotus Support documents
Lotus support by product
Lotus support downloads
Lotus support RSS feeds

Wikis

 Wikis
IBM Composite Applications
IBM Mashup Center
IBM Connections
IBM Connections Cloud Developers
IBM Docs
IBM Forms
IBM Mobile Connect
IBM Sametime
IBM SmartCloud for Social Business
IBM Web Experience Factory
Lotus Domino
Lotus Domino Designer
Lotus Expeditor
Lotus Foundations
Lotus iNotes
Lotus Instructor Community Courseware
Lotus Notes
Lotus Notes & Domino Application Development
Lotus Notes Traveler
Lotus Protector
Lotus Quickr
Lotus Symphony
IBM Web Content Manager
WebSphere Portal

Lotus Forums


 Lotus Forums
Notes/Domino 9.0
Notes/Domino 8.5 + Traveler
Notes/Domino XPages development forum
Notes/Domino 8
Notes/Domino 6 and 7
IBM Connections
IBM Mobile Connect
IBM Sametime
IBM SmartCloud Notes
Lotus Enterprise Integration
Lotus Protector
Lotus Quickr
Lotus SmartSuite