Skip to main content
This forum is closed to new posts and responses. New discussions are now taking place in the IBM Developer Answers forum.
 
developerWorks
AIX and UNIX
Information Mgmt
Lotus
New to Lotus
Products
How to buy
Downloads
Live demos
Technical library
Training
Support
Forums & community
Events
Rational
Tivoli
WebSphere
Java™ technology
Linux
Open source
SOA and Web services
Web development
XML
My developerWorks
About dW
Submit content
Feedback



developerWorks  >  Lotus  >  Forums & community  >  Notes/Domino 6 and 7 Forum

Notes/Domino 6 and 7 Forum

developerWorks

  

PreviousPrevious NextNext

Wrong date provided by @Now
Dennis Rudin 31.Mar.05 07:11 AM a Web browser
Notes Client 6.5.1 Windows XP


Kenneth and the rest of the community,

A long time has passed since this post was submitted and this is actually not a solution to Kenneth's issue, but rather a simular problem which I haven't found any logical reason for yet.

We have an application in which about 200 new documents are created each month. There is of course, as in most workflow applications a field (DateTime) saying the created date and time of each document. This field is set to contain @Now.

In a number of documents lately (9 of them actually) the date provided by @Now for this field has been eighter one month ahead of, or one month previous to the actual current date, causing us some serious trouble.

I have checked the local settings on the effected users' machines and everything seems to be in order, and they at least claim not to have changed anything regarding the date settings themselves.

One strange thing that I have noticed though is that when moving this date into a multiple value DateTime field along with a number of other dates and then looking at the field from another time zone, all dates are adjusted to the current time zone (field set to use user settings) except for the date provided by the field mensioned above, where the date and time stays the same no matter the time zone.

According to the property box I can see no difference between this problem date and the "correct" ones, but it looks the same, exept from the date difference of course.

According to the debugger the problem date looks the same as the others, and is specified as variant, as are the others.

So there you go community, any ideas on this one?




Wrong date in sent view (Kenneth B Rasmu... 25.Oct.04)
. . Wrong date provided by @Now (Dennis Rudin 31.Mar.05)
. . . . RE: Wrong date provided by @Now (Judy Kikkawa 20.Apr.05)


Document Options






  Document options
Print this pagePrint this page

Search this forum

Forum views and search


  Forum views and search
Date (threaded)
Date (flat)
With excerpt
Author
Category
Platform
Release
Advanced search

Member Tools


RSS Feeds

 RSS feedsRSS
All forum posts RSS
All main topics RSS
More Lotus RSS feeds

Resources

 Resources
Forum use and etiquette
Native Notes Access
Web site Feedback

Lotus Support

 Lotus Support
IBM Support Portal - Lotus software
Lotus Support documents
Lotus support by product
Lotus support downloads
Lotus support RSS feeds

Wikis

 Wikis
IBM Composite Applications
IBM Mashup Center
IBM Connections
IBM Connections Cloud Developers
IBM Docs
IBM Forms
IBM Mobile Connect
IBM Sametime
IBM SmartCloud for Social Business
IBM Web Experience Factory
Lotus Domino
Lotus Domino Designer
Lotus Expeditor
Lotus Foundations
Lotus iNotes
Lotus Instructor Community Courseware
Lotus Notes
Lotus Notes & Domino Application Development
Lotus Notes Traveler
Lotus Protector
Lotus Quickr
Lotus Symphony
IBM Web Content Manager
WebSphere Portal

Lotus Forums


 Lotus Forums
Notes/Domino 9.0
Notes/Domino 8.5 + Traveler
Notes/Domino XPages development forum
Notes/Domino 8
Notes/Domino 6 and 7
IBM Connections
IBM Mobile Connect
IBM Sametime
IBM SmartCloud Notes
Lotus Enterprise Integration
Lotus Protector
Lotus Quickr
Lotus SmartSuite