developerWorks  >  Lotus  >  Forums & community  >  Notes/Domino 6 and 7 Forum

Notes/Domino 6 and 7 Forum

developerWorks




Pls. Help: "Error accessing product object method" with db.replicationinfo
Andreas Ohlendorf 08/19/2011 05:06 AM
General 7.0.3 All Platforms


Hi,

I'm looking for some help on the following subject:

I'm using a modified 6.5.4 mail template to get some information about the mail users and to trigger certain functions on the client.

In the PostOpen event of the db, there's a call to some function which executes the tasks assigned by me.

One of the tasks is to remove some replication entries in the mail db and to create a new one when moving the user to a different mail server.
The code works fine 90% of the time... but then, on some clients - apparently 7.0.3 only - I get the error 219 "Error accessing product object method" when reading the replication information of the local replica of the mail file.

The code snippet (it's inside a class definition...):

Private Function AdjustReplication as Integer
Dim ReplInfo as NotesReplication
Dim ReplEntry as NotesReplicationEntry
Dim colEntries as Variant

On Error Goto ErrHandler

AdjustReplication = False
Call me.ErrorLog.Write (LEVEL_DEBUG, GetThreadInfo (1) & " started...")

' dbLocalMail points to local replica of mail file and is assigned elsewhere...
if me.dbLocalMail is Nothing then Exit Function
Call me.ErrorLog.Write (LEVEL_DEBUG, "Checkpoint 1")
if not me.dbLocalMail.isOpen then Exit Function
Call me.ErrorLog.Write (LEVEL_DEBUG, "Checkpoint 2")

set ReplInfo = me.dbLocalMail.ReplicationInfo
Call me.ErrorLog.Write (LEVEL_DEBUG, "Checkpoint 3")

..... some more code which is not reached..... :,-((

End Function

In the log, Checkpoints 1 and 2 are ok, checkpoint 3 is not reached, instead there is this error msg...

Any ideas about what's wrong here? Is this some 7.0.3 specific error?
I would appreciate any help - I have to move about 2000 users from one mail server to another and this function would be VERY helpful to clean up some administrative issues we had in the past (roaming users only working with local replicas...).

Thx in advance for any tipps...

Regards
Andreas

Go back