Skip to main content
BlueMix free trial
 
developerWorks
AIX and UNIX
Information Mgmt
Lotus
New to Lotus
Products
How to buy
Downloads
Live demos
Technical library
Training
Support
Forums & community
Events
Rational
Tivoli
WebSphere
Java™ technology
Linux
Open source
SOA and Web services
Web development
XML
My developerWorks
About dW
Submit content
Feedback



developerWorks  >  Lotus  >  Forums & community  >  Notes/Domino 6 and 7 Forum

Notes/Domino 6 and 7 Forum

developerWorks

  

Sign in to participate PreviousPrevious NextNext

RE: Layout Region Problem
Kevin Pettitt 2.Oct.06 04:03 PM a Web browser
Applications Development 6.5.4 All Platforms


Andre's recommendation solved the problem. The exact error message (in case anybody is searching for it here), is:

You have attempted to load or place a layout region into a table. Layouts are not allowed within tables.

When The Error Appears

This message only appeared when I tried to open the specific document in question. No error is raised if you try to refresh documents in a view using @Command([ToolsRefreshSelectedDocs]) - the operation simply fails when it gets to the document. I would throw in a general recommendation to verify that a mass document refresh has worked considering the possibility of such a silent failure.

The Cause

In my case, I had updated the design of an old, vintage 4.x Notes database. The main form contained a Rich Text field that in my new design was placed within a table. The problem arose on a document in which an old 4.x mail message had been pasted into the rich text field. Old-timers will recall that the 4.x mail template used a layout region in the header (where all the From/To/cc/Subject stuff appeared). Since this header was included in the pasted message, it amounted to a violation of the "no layout regions in tables" rule.

The Solution

Modify the design of the form to place the rich text field OUTSIDE of the table.

Kevin




Layout Region Problem (vinay peshave 24.Mar.06)
. . RE: Layout Region Problem (Andre Guirard 24.Mar.06)
. . . . RE: Layout Region Problem (Kevin Pettitt 2.Oct.06)


Document Options






  Document options
Print this pagePrint this page

Search this forum

Forum views and search


  Forum views and search
Date (threaded)
Date (flat)
With excerpt
Author
Category
Platform
Release
Advanced search

Sign In or Register

 Sign In or Register
Sign in
Forgot your password?
Forgot your user name?
Create new registration

Member Tools


RSS Feeds

 RSS feedsRSS
All forum posts RSS
All main topics RSS
More Lotus RSS feeds

Resources

 Resources
Forum use and etiquette
Native Notes Access
Web site Feedback

Lotus Support

 Lotus Support
IBM Support Portal - Lotus software
Lotus Support documents
Lotus support by product
Lotus support downloads
Lotus support RSS feeds

Wikis

 Wikis
IBM Composite Applications
IBM Mashup Center
IBM Connections
IBM Connections Cloud Developers
IBM Docs
IBM Forms
IBM Mobile Connect
IBM Sametime
IBM SmartCloud for Social Business
IBM Web Experience Factory
Lotus Domino
Lotus Domino Designer
Lotus Expeditor
Lotus Foundations
Lotus iNotes
Lotus Instructor Community Courseware
Lotus Notes
Lotus Notes & Domino Application Development
Lotus Notes Traveler
Lotus Protector
Lotus Quickr
Lotus Symphony
IBM Web Content Manager
WebSphere Portal

Lotus Forums


 Lotus Forums
Notes/Domino 9.0
Notes/Domino 8.5 + Traveler
Notes/Domino XPages development forum
Notes/Domino 8
Notes/Domino 6 and 7
IBM Connections
IBM Mobile Connect
IBM Sametime
IBM SmartCloud Notes
Lotus Enterprise Integration
Lotus Protector
Lotus Quickr
Lotus SmartSuite