Skip to main content
This forum is closed to new posts and responses. New discussions are now taking place in the IBM Developer Answers forum.
 
developerWorks
AIX and UNIX
Information Mgmt
Lotus
New to Lotus
Products
How to buy
Downloads
Live demos
Technical library
Training
Support
Forums & community
Events
Rational
Tivoli
WebSphere
Java™ technology
Linux
Open source
SOA and Web services
Web development
XML
My developerWorks
About dW
Submit content
Feedback



developerWorks  >  Lotus  >  Forums & community  >  IBM Lotus Notes/Domino 8.5 Forum (includes Lotus Notes Traveler)

IBM Lotus Notes/Domino 8.5 Forum (includes Lotus Notes Traveler)

Subject: Illegal function call and Shell function
Feedback Type: Problem
Product Area: Notes Client
Technical Area: Application Development
Platform: Windows
Release: 8.5.1
Reproducible: Always

Hi,
I am still struggling with making the Shell function work in Lotus Notes 8.5.1 FP2.

The situation:
We have an integrator with another product, which installs a .nsf file and adds a icon to the users Lotus Notes.
In Windows XP/Notes 7/Notes 8 etc, it works fine, we forward the document from a database, it has a button on it and an executable file, the user presses the button, and the file is extracted to their PC and runs.

In Windows 7 this still doesn't work, due to problems with User Account Control (UAC). Turning off UAC resolves this first issue, but that is not really an option given the number of users.

If you use the Shell function to trigger e.g. CALC.exe for Windows Calculator, it works fine.
Presumably it works fine for other Windows programs also.
But for a customized executable, it always returns 'Illegal function call'.

Please explain the way round this problem..

Additionally, I'd like to point out the following:
If you create a button in an email with Simple Action, @Formula function, and user say @Command([Execute];"C:\\Users\\me\\AppData\\Local\\Temp\\CustomExecutableFileName.exe"), then this works as expected - that is, it gives a UAC prompt on which you can select 'Yes' and then the program runs.
(Frankly the UAC prompt is annoying to, but at least it works as Microsoft designed it this way).
The LotusScript Shell command does not give this prompt, and instead simply errors out with Illegal function call.
And you cannot run an @Command from LotusScript, unless someone knows of a way?


Feedback number WEBB8HMJJZ created by Generic Notes Developer on 06/08/2011

Status: Open
Comments:

Illegal function call and Shell fun... (Generic Notes D... 8.Jun.11)
. . Have you tried an API call instead?... (David Gilmore 8.Jun.11)
. . . . API scary (Generic Notes D... 9.Jun.11)
. . . . . . The R6 Forum has examples... (David Gilmore 9.Jun.11)
. . Try using WScript.Shell instead (Wayne Gibbons 8.Jun.11)
. . . . WScript.Shell (Generic Notes D... 9.Jun.11)




Printer-friendly

Search this forum

Member Tools


RSS Feeds

 RSS feedsRSS
All forum posts RSS
All main topics RSS
More Lotus RSS feeds

Resources

 Resources
Forum use and etiquette
Native Notes Access
Web site Feedback

Lotus Support


 Lotus Support
IBM Support Portal - Lotus software
Lotus Support documents
Lotus support by product
Lotus support downloads
Lotus support RSS feeds

Wikis

 Wikis
IBM Composite Applications
IBM Mashup Center
IBM Connections
IBM Connections Cloud Developers
IBM Docs
IBM Forms
IBM Mobile Connect
IBM Sametime
IBM SmartCloud for Social Business
IBM Web Experience Factory
Lotus Domino
Lotus Domino Designer
Lotus Expeditor
Lotus Foundations
Lotus iNotes
Lotus Instructor Community Courseware
Lotus Notes
Lotus Notes & Domino Application Development
Lotus Notes Traveler
Lotus Protector
Lotus Quickr
Lotus Symphony
IBM Web Content Manager
WebSphere Portal

Lotus Forums


 Lotus Forums
Notes/Domino 9.0
Notes/Domino 8.5 + Traveler
Notes/Domino XPages development forum
Notes/Domino 8
Notes/Domino 6 and 7
IBM Connections
IBM Mobile Connect
IBM Sametime
IBM SmartCloud Notes
Lotus Enterprise Integration
Lotus Protector
Lotus Quickr
Lotus SmartSuite