developerWorks  >  Lotus  >  Forums & community  >  IBM Lotus Notes/Domino 8.5 Forum (includes Lotus Notes Traveler)

IBM Lotus Notes/Domino 8.5 Forum (includes Lotus Notes Traveler)



Feedback Type Problem
Subject Views not building when view option 'ODBC Access Generate unique keys in index' is enabled.
Product Area Domino Server
Technical Area Application Development
Platform Windows
Release 8.5.2
Hello all. Need some ideas.

Have some views in a long running database that did work, but somewhere over time during design and server upgrades have started failing.

When the 'unique keys in index' option for ODBC Access is enabled, the error message "Entry not found in index" occurs.

While troubleshooting, I've found that it's somehow tied to the name of the form being used for the View Selection. Server is currently 8.5.2FP2.

Things that did NOT work:
-Stripping everything out of the form, it still won't build the view
- Backing up the form, and creating a brand new, blank form with the same name also fails.


What does let the view build
- Unchecking the 'unique keys in index' option. Duh, but not a real solution.
- Changing the view selection to some other form.
- Simply renaming the existing form to something else and updating the view selection formula.


So why can I simply rename the form and it work, but if I name it back, it doesn't. Is the server caching something?


I have even tried renaming the forms so it works, then running compact, fixup, and updall, and then switching the form name back and it still doesn't want to play. A work around appears to be to give the form a new name, and an alias of the old name, but I'd rather things just work as they should.

Thank you for any suggestions you can provide.

Feedback number WEBB8PAMQE created by erik r welch on 09/18/2019

Go back