Jun 24, 2015 3:34 PM
17 Posts

Traveler 9 50% cpu usage on idle

  • Category: Notes Traveler
  • Platform: Windows
  • Release: 9.0.1
  • Role: Administrator
  • Tags:
  • Replies: 4

Hi,

There is this Traveler that uses 50% cpu all day, even when no there is no active client synching.

The command tell traveler threads reports 25 thread, 20 of then busy. Then, the command tell traveler active says there is 0 active user.

Restarting the traveler task solve the problem but then a few hours later the CPU goes again from 1 to 50%

How can I diagnose what the problem is without sending a PMR to IBM? 

The traveler status is green BTW.

I searched for the DelQ thread info and could not find any info on the traveler manual. What is the DelQ thread? I always have 10 of them

[1584:0021-198C] 24/06/2015 01:20:58 p.m.  Traveler: Shutdown requested: false
[1584:0021-198C] 24/06/2015 01:20:58 p.m.  Traveler: Threads total: 25
[1584:0021-198C] 24/06/2015 01:20:58 p.m.  Traveler: Threads available: 5
[1584:0021-198C] 24/06/2015 01:20:58 p.m.  Traveler: Threads busy: 20
[1584:0021-198C] 24/06/2015 01:20:58 p.m.  Traveler: Threads deadlocked: 0
[1584:0021-198C] 24/06/2015 01:20:58 p.m.  Traveler: Threads monitor deadlocked: 0
[1584:0021-198C] 24/06/2015 01:20:58 p.m.  Traveler: 
[1584:0021-198C] 24/06/2015 01:20:58 p.m.  Traveler: -- Busy Thread Counts (Name: Current / Peak / Max) --
[1584:0021-198C] 24/06/2015 01:20:58 p.m.  Traveler:    DS: 0 / 3 / 5000
[1584:0021-198C] 24/06/2015 01:20:58 p.m.  Traveler:    PS: 0 / 4 / 200
[1584:0021-198C] 24/06/2015 01:20:58 p.m.  Traveler:    Worker: 0 / 4 / 5000
[1584:0021-198C] 24/06/2015 01:20:58 p.m.  Traveler:    TC: 1 / 2 / 50
[1584:0021-198C] 24/06/2015 01:20:58 p.m.  Traveler:    Alarm: 0 / 4 / 20
[1584:0021-198C] 24/06/2015 01:20:58 p.m.  Traveler:    VC: 0 / 3 / 20
[1584:0021-198C] 24/06/2015 01:20:58 p.m.  Traveler:    Mntr: 3 / 4 / 5000
[1584:0021-198C] 24/06/2015 01:20:58 p.m.  Traveler:    DelQ: 10 / 10 / 50
[1584:0021-198C] 24/06/2015 01:20:58 p.m.  Traveler:    Misc: 6 / 6 / 5000
[1584:0021-198C] 24/06/2015 01:20:58 p.m.  Traveler:    HTTP: 2 / 11 / 400

 

Any tips are welcome,

Regards,

Oliver

 

Jun 25, 2015 1:04 AM
82 Posts
tell traveler status

Hi, 

When it reached 50% , do a 'tell traveler status' in the console. If it red or yellow, it will have explanation.

Jun 25, 2015 11:44 AM
17 Posts
Always 49% and green

Hi,

The CPU is always at 49% to be exact, and the status is always green.

I found more info about the cpu usage, just look at:

tell traveler stat show cpu.pct.*

[1584:0021-198C] 24/06/2015 01:45:57 p.m.  Traveler:    CPU.Pct.000-010 = 9
[1584:0021-198C] 24/06/2015 01:45:57 p.m.  Traveler:    CPU.Pct.040-050 = 1398
[1584:0021-198C] 24/06/2015 01:45:57 p.m.  Traveler:    CPU.Pct.050-060 = 2

The traveler server is almost always in 49% cpu usage state

Jun 29, 2015 5:17 PM
17 Posts
Another app was on 443

It seems to be fixed now. This installation of traveler was not running on port 443, because there was another web app running on port 443. We stopped that other app and now the port 443 is free and traveler is working as expected, with less than 10% CPU usage.

Will wait another week to really mark this as fixed:

tell traveler stat show cpu.pct.*

[175C:002C-377C] 29/06/2015 03:22:17 p.m.  Traveler:    CPU.Pct.000-010 = 368

 

Oct 20, 2015 5:28 PM
2 Posts
Traveler 9 50% cpu usage on idle

Another thing you want to consider when experiencing a high cpu utilization for traveler is to check the disk drive. We recommend that the average queue length should be 0.2 and below. You may use this URL as a reference.: http://www-01.ibm.com/support/docview.wss?uid=swg21615973

But glad to know that the issue is now resolved.