FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.


Aug 26, 2014, 3:18 AM
117 Posts

JVM was not upgraded

  • Category: Install
  • Platform: Windows
  • Release: 9.0.1
  • Role: Administrator
  • Tags:
  • Replies: 7

Hi,

I have just upgraded Domino 9.0.1 FP1 to 9.0.1 FP2.

This is a test environment on Windows 7 Pro SP1 32.

"Congratulations, you have successfully upgraded this product. WARNING: JVM was not upgraded. Please, see UPGRADE.log and jvmpatcher.log for détails."

Patching tree diff from ".\jvm" to ".\jvm_patched" using diff file ".\UPTMP0044.TMP"...
    You are attempting to patch:
      pwi3260sr15fp1-20140110_01(SR15 FP1))
    With a patch that is valid for:
      src1 pwi3260sr14ifix-20130729_03(SR14+IV46117))
    Tree diff file patch failed.

Server works as usual.

Aug 26, 2014, 9:54 AM
98 Posts
I had the same issue...
...in my test environment. I could solved it with the following steps:
- renamed 'jvm' directory
- reinstalled Domino 9.0.1
- then installed FP2
Aug 26, 2014, 11:42 AM
122 Posts
Re: JVM was not upgraded
Hello Jean-Pierre!

See the following TN regarding the issue.It has been reported to Quality Engineering as APAR LO80268

Title:        Domino 9.0.1 Fix Pack 1 installer returns message: "WARNING: JVM was not upgraded"
Doc #:        1675089
URL:        
http://www.ibm.com/support/docview.wss?uid=swg21675089

Best Regards!
Rodrigo
Aug 26, 2014, 3:11 PM
60 Posts
You had already upgraded jvm earlier...
Could it be that  you installed a standalone jvm patch?  Log message you quote says that  you already have a newer version of jvm than the one packaged in fixpack.
Aug 26, 2014, 5:50 PM
117 Posts
Thanks for your help

@Michael : I will try reinstall Domino tomorrow.

@Rodrigo : Thanks for this information. If necessary, I will wait for the fix.

@Irina : I have no idea to what a "a standalone jvm patch" can be installed .... ???

Jean-Pierre

NB : More news tomorrow.

Aug 27, 2014, 7:32 AM
117 Posts
Full reinstall worked

Reinstall Domino 9.0.1 + FP2 worked OK.

Thanks.

Jean-Pierre

Sep 5, 2014, 5:42 PM
113 Posts
show jvm verifies your java updated
can issue a show jvm to verify your java version
after my install on 901fp2 , my server shows:

> show jvm
[34708:0002-3457C] 09/05/2014 04:45:46 PM  JVM: Java Virtual Machine initialized
.
[34708:0002-3457C] 09/05/2014 04:45:46 PM  Java runtime version: pwi3260sr16-201
40418_01 (SR16)
[34708:0002-3457C] 09/05/2014 04:45:46 PM  JVM version: JRE 1.6.0 IBM J9 2.4 Win
dows Server 2008 R2 x86-32 jvmwi3260sr16-20140416_196573 (JIT enabled, AOT enabl
ed) J9VM - 20140416_196573 JIT  - r9_20130920_46510ifx5 GC   - GA24_Java6_SR16_2
0140416_1614_B196573
Aug 27, 2014, 7:32 AM
117 Posts
Full reinstall worked

Reinstall Domino 9.0.1 + FP2 worked OK.

Thanks.

Jean-Pierre


FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.