Sep 6, 2016, 11:25 AM
8 Posts

Domino Fix Pack installer silently fails with perl 5.2x on Linux (Ubuntu)

  • Category: Domino Server,Install
  • Platform: Linux
  • Release: 9.0.1
  • Role: Administrator
  • Tags: 9.0.1,LINUX,16.04,ubuntu,Perl,Installer,Fix pack,domino,Silent,fail
  • Replies: 4
When the Domino 9.0.1 fixpack and hotfix installer fails without error after displaying the following:

IBM Domino for Unix Install Program
------------------------------------
Installer is initializing. It may take a few minutes, please, wait.


This blog post might be usefull (and yes, I know that Ubuntu Server 16.04 is not a supported platform): http://woonjas.linuxnerd.org/web/woonblog.nsf/d6plinks/NWEA-ADHQ29
Sep 6, 2016, 3:03 PM
60 Posts
Could you check if you have anything in /tmp/nuish.err
If not try running with
./install -is:log  /tmp/mylog.txt
and paste its contents here.
Sep 6, 2016, 4:19 PM
17 Posts
try this "step by step"

Which version of Ubuntu are you using? 16.04? If so, I got FP for Domino working, the general instructions are in spanish and some steps are incomplete, but the general idea is there:

 

Para Ubuntu 16.04, que viene con Perl v5.22:
Los Fix Packs de IBM Domino usan perl, y una sintaxis que en perl v5.22 qua no funciona. En v5.20 aún funciona. Por lo tanto debemos usar esa versión de Perl.

==========================================
1) Instalar Prerequisitos
==========================================
sudo apt-get install gcc
sudo apt-get install build-essential

==========================================
2) Instalar perlbrew
==========================================
curl -L https://install.perlbrew.pl | bash

Luego:
    Append the following piece of code to the end of your ~/.bash_profile and start a
    new shell, perlbrew should be up and fully functional from there:

    source ~/perl5/perlbrew/etc/bashrc
    
Finalmente reiniciar consola (para que tome el source).

==========================================
3) Usar perlbrew
==========================================
perlbrew --notest install perl-5.20.2
perlbrew switch perl-5.20.2

==========================================
4) Ajustes en la instalación de IBM Domino
==========================================
4.1: Habilitar perlbrew en root y switch a versión perl
Como instalación de IBM Domino y sus FP se hacen como root (sudo -s), una vez cambiado a root, ejecutar:

export PERLBREW_ROOT=/home/<USUARIO>/perl5/perlbrew
source $PERLBREW_ROOT/etc/bashrc
perlbrew switch perl-5.20.2
perl -v
    -> debe dar la versión correcta

4.2: Ajustar script de instalación de IBM Domino o FP

El script de instalación de FP de IBM Domino (./install) hay que editarlo, pues invoca PATH y EXPORT, lo que

Verificar versión de Perl:
perl -v

Sep 6, 2016, 4:21 PM
17 Posts
the problem is the version of perl

The Domino FP installer uses some commands that are deprecated for some time in recent versions of pearl. So, the easiest trick is to downgrade the perl version. Another fix would be to edit all the perl script the FP uses and update the deprecated commands...

Jan 5, 2017, 11:36 AM
4 Posts
Ubuntu Fixpack installation Fixpack 7 and 901FP7HF370

Possible error in Ubuntu Fixpack installation Fixpack 7 and 901FP7HF370 (IBM Verse on Premise)

 in the path from the fixpack there is a file install/tools/lib/NIC.pm

 in line 80 you should replace the value

if (defined(@{$scr->{target_hosts}})) 

by

if (@{$scr->{target_hosts}}) 

Save the file after that the installation will works.