FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.


Jul 12, 2017, 11:26 AM
7 Posts
topic has been resolvedResolved

Can't Connect to Server From Client

  • Category: Domino Server
  • Platform: Windows
  • Release: 9.0.1
  • Role: Administrator,Developer
  • Tags: Server,Error,Connection
  • Replies: 9

I am hoping I can get some help on this topic quickly.

We had this issue with another server a few months ago and ended up rebuilding the server to solve the issue which I am not willing to do this time around due to the amount of data and the importance of this server's data.

We had a power outage this morning and when the server came back up we are unable to connect to it via the Domino Client. I can access it just fine from the Browser. Agents that ran and contact it crash, yet replication is working.  I am totally perplexed as I am a developer playing the role of an administrator.

If anyone could point me in the right direction that would be very helpful.

The connection documents and server configurations all look good to me and have not been changed. We do not use any kind of hosts file. 

Thanks in Advance

Tony

Jul 12, 2017, 11:33 AM
320 Posts
suggestions

I was going to suggest that maybe the server picked up a new ip address   Check the notes client to see if there are connection doc.

 

You check for multiple notes.ini on the server and perhaps it is using the wrong one.

 

Try a trace to server and see what happens

Jul 12, 2017, 11:47 AM
7 Posts
Thanks but no dice

Thanks for the quick reply, but not luck.

1) The conneciton document is set-up correctly, verified this on my machines. Plus, this is affecting all internal users and worked fine yesterday. :-/

2) Could only find one notes.ini file and will dig through it to see if I find anything odd.  (I may just shut down the server and replace the NAB and the INI and see if that does anything, hopefully last nights back-up worked correctly)

3) When I do a command prompt ping and trace everything works correctly. When I run a trace from within the notes client I get a response like this:

Determining path to server SERVER1
Available Ports:  TCPIP
Checking normal priority connection documents only...
Allowing wild card connection documents...
Checking for SERVER1 at last known address 'SERVER1.SERVER1.com' on TCPIP...
  Unable to connect to SERVER1 on TCPIP (Remote system no longer responding)
No answer at last known address
Enabling name service requests and probes...
Requesting address of SERVER1 from SERVER2 on TCPIP
  Using address '10.41.1.34' for SERVER2 on TCPIP
Address 'SERVER1.SERVER1.com' returned for SERVER1 on TCPIP
The server was not responding at this address
Unable to find any path to SERVER1 because Remote system no longer responding

 

No luck. All the configurations and set-ups look good to me.  All our internal users are dead in the water right now, really weird.

Thanks again.

 

Jul 12, 2017, 12:22 PM
7 Posts
Getting Closer (Hopefully)

I used NOTESConnect and I found/confirmed that it is a NRPC/Port 1352 issue.  Is this controlled in the NAB or ini or just on at the pc level? The network admin is looking through the firewall and ports now.

Would updating the NAB from last nights back-up do anything?

The Server Document looks good to me, still browsing through. 

 

As for telnet I can't connect via port 1352 so that is definitely the issue. Just need to figure out how to open it up.

I do appreciate the quick replys on this. Thank you.

Tony

Jul 12, 2017, 12:29 PM
59 Posts
suggestion

here's a way to start trouble-shooting:

1) determine the server's IP address at the server (ipconfig at the command line, assuming a windows server)

2) on a client, press ctrl-o (file>database>open). instead of choosing a server name, type in the server's IP address for the server name

does the client connect to the server and give you a list of database names? If no, there is some kind of connectivity or addressing problem between the client and the server. if you do get a list of database names, there is a problem somewhere in the configuration of the clients or the server nab.

hope that is helpful

Jul 12, 2017, 12:37 PM
7 Posts
Firewall Doesn't Seem to be it

The servers are on the same network and there is no subnet.  The only firewall on the server is the windows firewall and it has been disabled.

My network admin is looking for a resolution via LotusNotes he doesn't think it is a network issue.  Running netstat -np on the server it seems like the server is listening but only on >>  [::]:1352

Is there a service in the Domino start-up that tells the server to use this port?

 

Thanks.

Tony

 

Jul 12, 2017, 12:40 PM
362 Posts
Hm, if y'can't connect along 1352 it could be a firewall issue, too.

Are you jumping into another network/subnet to get at this server, and maybe going through a firewall?

Oh, I see you're having the network guy check.

And the local machine firewalls, they're good to check, but they shouldn't have changed if the server's been running all night.

Jul 12, 2017, 12:55 PM
7 Posts
Resolved

We aren't 100% sure what the issue was, but it is resolved and we can now connect to the server via the client.

The final solution was setting this ini setting back to 0 form 1 -- TCP_EnableIPV6=0

After changing this item and rebooting everything seems back on track. I am hoping this doesn't cause any other issues. I still think its a network issue.

 

Thank you for everyone who jumped on and helped out. I apprecaite the quickness in your replies!

Have a great day, I might just go home. :)

Tony


FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.