This forum is closed to new posts and responses. New discussions are now taking place in the IBM Developer Answers forum.


May 2, 2014, 9:13 AM
1 Posts

Ubuntu 14.04 LTS plans?

  • Category: Notes Client
  • Platform: Linux
  • Release: 9.0.1
  • Role: Administrator,Developer,End User
  • Tags: Linux,Ubuntu,Trusty,14.04
  • Replies: 3

Now that the latest Ubuntu LTS has been released, I'm curious what the plans are for supporting it. Is there already a new IBM Notes client released? If not, does anyone know when they might release support for it? I would be happy to beta test and provide feedback.

Thanks.

May 4, 2014, 3:56 AM
2 Posts
Notes 9.0.1 and FP1 install guide for Ubuntu 14.04
Hello,

Thanks for your eagerness for trying it! Here is a technote of how to install Notes 901 and FP1 on Ubuntu 14.04 LTS, which is in publishing process and I copied here for your trying firstly. It will be support in upcoming release.

----------------------------------------------------------------------------------------------------------------------
Notes 9.0.1 and FP1 install guide for Ubuntu 14.04

Notes 9.0.1

Prerequisite
Download Notes 9.0.1 installation package, launch linux shell window and go to the directory of Notes 9.0.1 installation package, then execute following commands to correct those packages which have been deprecated in Ubuntu 14.04:
  1. sudo dpkg -X ibm-notes-9.0.1.i586.deb ./notes
  2. sudo dpkg -e ibm-notes-9.0.1.i586.deb ./notes/DEBIAN
  3. edit decency info from ./notes/DEBIAN/control -- change libcupsys2 to libcups2
  4. sudo dpkg -b notes ibm-notes-9.0.1.i586.deb
(I). Install Notes via GUI.
GUI install on Ubuntu 14.04 doesn't work due to Ubuntu defect (https://bugs.launchpad.net/canonical-identity-provider/+bug/1306379), the end user needs to install Notes via command line.)

(II). Install Notes via Command line.
* Step 1~6 are only required before your install Notes on Ubuntu 14.04 at first time, as Notes client has dependencies on some deprecated packages.
1. sudo apt-get install libbonobo2-0
2. sudo apt-get install libbonoboui2-0
3. sudo apt-get install libgconf2-4
4. sudo apt-get install libgnome-desktop-2-17
5. sudo apt-get install libgnomeui-0
6. sudo apt-get install libjpeg62

* Step 7~11 are standard steps to install Notes product on Ubuntu 14.04
7. sudo dpkg -i ibm-notes-9.0.1.i586.deb
8. sudo dpkg -i ibm-activities-9.0.1.i586.deb
9. sudo dpkg -i ibm-sametime-9.0.1.i586.deb
10. sudo dpkg -i ibm-opensocial-9.0.1.i586.deb
11. sudo dpkg -i ibm-feedreader-9.0.1.i586.deb


Notes 9.0.1 FP1

Prerequisite
Notes 9.0.1 GM should be installed and FP1 installation package is available

(I). Install Notes 9.0.1 FP1 via GUI.
GUI install on Ubuntu 14.04 doesn't work due to defect (https://bugs.launchpad.net/canonical-identity-provider/+bug/1306379), the end user needs to install Notes via command line.

(II). Install Notes 9.0.1 FP1 via Command line.
Execute the install script in package by following command:
    sudo ./ibm_notes_fixpack.sh
May 19, 2014, 10:07 AM
29 Posts
Thanks for this guide, I just want to ..
stress the importance of building better Package File with proper dependendies, even to Depracated libraries:
Deep Link
  Date Topic
10.dec.13 Lotus Notes Client on popular Linux Desktops


eventually, we would not need tweaking the 'off the shelf' package from IBM.

Cheers
/Peter
Jun 6, 2014, 8:04 AM
3 Posts
Notes 9.0.1 on Ubuntu 14.04 x64

on a fresh Ubuntu 14.04 64bit I had to do additional steps:

- Install the following 32bit packages with "sudo apt-get install ..." :

gdb:i386
ibart-2.0-2:i386
libasound2:i386
libatk1.0-0:i386
libbonobo2-0:i386
libbonoboui2-0:i386
libgconf2-4:i386
libgnome-desktop-2-17:i386
libgnomeui-0:i386
libjpeg62:i386
libpam0g:i386
libpango1.0-0:i386
libstdc++6:i386
libxkbfile1:i386
libxp6:i386
libxss1:i386
libxt6:i386
libxtst6:i386
iproute2:i386

 

 

- rebuild Sametime package with different dependencies, because Ubuntu 14.04 has no iproute:i386 package.:

dpkg -X ibm-sametime-9.0.1.i586.deb ./sametime
dpkg -e ibm-sametime-9.0.1.i586.deb ./sametime/DEBIAN
 --> edit dependency info from ./sametime/DEBIAN/control --> delete iproute
dpkg -b sametime ibm-sametime-9.0.1.i586.deb

 

After this I could install the packages.

 

But Notes does not work as expected:

After starting Notes Client and agreeing to the license the configuration dialog box (Username, Servername) comes up.

In this dialog box I can fill in the information and click to continue. Also it asks for the password (we are using ID Vault). But

then in the splash screen I only see "verifying your authorization to use server". And with this messages it stays apparently forever :-(

 

Maybe anybody can help?

 

 


This forum is closed to new posts and responses. New discussions are now taking place in the IBM Developer Answers forum.