Dec 9, 2013 5:02 PM
7 Posts

Linux Crash on openSUSE 13.1 libgnomeprintui-2.18.6 when sending email

  • Category: Notes Client
  • Platform: Linux
  • Release: 9.0.1
  • Role: Administrator,End User
  • Tags:
  • Replies: 13

I recently upgraded to openSUSE 13.1 (which I know isn't supported) which brought upgrades to libgnomeprintui and other gnome libraries which are required. Since then I get a core dump, with the following information: 

[16431:00002-3026778624] 12/09/2013 12:33:14 PM  Dynamic Client Configuration shutdown
[16301:00002-2996955392] (MailSendNoteActual)- after lookup Total recipients 1
Unhandled exception
Type=Segmentation error vmState=0x00040000
J9Generic_Signal_Number=00000004 Signal_Number=0000000b Error_Value=00000000 Signal_Code=00000001
Handler1=B7373CDA Handler2=B7349021 InaccessibleAddress=00000C00
EDI=B73D4760 ESI=09EE56B8 EAX=00000C00 EBX=A2289000
ECX=00000001 EDX=A07121B4
EIP=A224FA8E ES=007B DS=007B ESP=BFCF1B64
EFlags=00210206 CS=0073 SS=007B EBP=BFCF1B9C
Module=/usr/lib/libgobject-2.0.so.0
Module_base_address=A2238000 Symbol=g_object_get_qdata
Symbol_address=A224FA70
Target=2_40_20130704_155156 (Linux 3.12.0-1.ge8fa6b4-desktop)
CPU=x86 (4 logical CPUs) (0x1f1638000 RAM)
----------- Stack Backtrace -----------
(0xB733CB76 [libj9prt24.so+0xbb76])
(0xB734866C [libj9prt24.so+0x1766c])
(0xB733CC09 [libj9prt24.so+0xbc09])
(0xB733CD2C [libj9prt24.so+0xbd2c])
(0xB733C9A8 [libj9prt24.so+0xb9a8])
(0xB734866C [libj9prt24.so+0x1766c])
(0xB733CA1C [libj9prt24.so+0xba1c])
(0xB7374AA6 [libj9vm24.so+0xfaa6])
(0xB7374726 [libj9vm24.so+0xf726])
(0xB734866C [libj9prt24.so+0x1766c])
(0xB7373F0B [libj9vm24.so+0xef0b])
(0xB7373D5E [libj9vm24.so+0xed5e])
(0xB7349199 [libj9prt24.so+0x18199])
__kernel_rt_sigreturn+0x0 (0xB77D640C [linux-gate.so.1+0x40c])
(0xA0712236 [<unknown>+0x0])
JVM_InvokeMethod+0x92 (0xB73DF9C4 [libjvm.so+0xa9c4])
JVM_InvokeMethod+0x58 (0xB7463398 [libjvm.so+0x3398])
Java_sun_reflect_NativeMethodAccessorImpl_invoke0+0x34 (0xA651A804 [libjava.so+0x12804])
(0xA66A40F7 [<unknown>+0x0])
JVM_InvokeMethod+0x92 (0xB73DF9C4 [libjvm.so+0xa9c4])
JVM_InvokeMethod+0x58 (0xB7463398 [libjvm.so+0x3398])
Java_sun_reflect_NativeMethodAccessorImpl_invoke0+0x34 (0xA651A804 [libjava.so+0x12804])
(0xA66A40F7 [<unknown>+0x0])
(0xB7383D85 [libj9vm24.so+0x1ed85])
(0xB73B9ABD [libj9vm24.so+0x54abd])
(0xB734866C [libj9prt24.so+0x1766c])
(0xB73B9B9B [libj9vm24.so+0x54b9b])
(0xB738437D [libj9vm24.so+0x1f37d])
(0xB73823C4 [libj9vm24.so+0x1d3c4])
startJavaJNI+0x418 (0xB77BF3D9 [eclipse_1407.so+0x83d9])
startJavaVM+0x24 (0xB77C0878 [eclipse_1407.so+0x9878])
run+0x59d (0xB77BA14B [eclipse_1407.so+0x314b])
(0x080490EE [notes2+0x10ee])
__libc_start_main+0xf3 (0xB75F99D3 [libc.so.6+0x199d3])
 

 

The error / crash is repeatable when I send an email message, which makes me believe it's part of the libgnomeprintui handles. 

 

Anyone else experience this?

Dec 11, 2013 11:37 PM
48 Posts
Domino Crash NSD File

Hi, Can you share the nsd crash file?

Dec 17, 2013 5:45 AM
1 Posts
Notes 9 crashes ...
 
Hello,
Unfortunately, I can confirm that "Notes" on SuSe 13.1 crashes.

But, the following is very strange:

If the user's directory is on a remote computer and it will be mounted via NFS "Notes" does not crash.

Once the homedirectory is on the same computer as Notes runs, notes crashes after 2-3 minutes.

It is not relevant, how the home directory is mounted (directly for example: /dev/sda2 /home/ or per nfs wsname:/.home/user /home/user)

"Notes" crashes always.

 

 

Can you help me?
Which information or log files should I provide you?

 

Thank you! 

Alpar

 

Dec 20, 2013 1:53 AM
4 Posts
Notes9 won't start on openSUSE 13.1

I've got a fresh install of  openSUSE 13.1 and put Notes 9 on that, but Notes will not start.  It pops up its splash screen for a moment, then it's gone.   I don't see any NSD log from this, I don't think it gets far enough to produce it.  However, in  lotus/notes/data/workspace/logs, there are these files:


error-log-0.xml  Log_Viewer.xml   shutdown.log     trace-log-1.xml   Viewer_Translations.js
error-log-1.xml  rcplauncher.log  trace-log-0.xml  Trace_Viewer.xml

I also tried Ben Kevan's workaround, but it made no difference.

Can you help?
 

 

Dec 20, 2013 11:05 AM
7 Posts
Lotus Notes 9 Crash

Craig, 

How did you install the packages? What desktop environment are you using? 

Dec 20, 2013 1:22 PM
4 Posts
Notes9 won't start on openSUSE 13.1

Hi Ben,

For desktops, I've tried both Gnome and KDE (both fully installed). I started with the public 90 day trial version. When that failed I installed RPMs that are available internally in my company, which I admit are slightly customized for redhat, but in the past have always installed without a hitch on opensuse. In both cases I'm  talking about the latest package,  ibm-lotus-notes-9.0.1 (20131022).

Craig

Dec 21, 2013 9:56 PM
7 Posts
output

Craig, 

 

Can you run /opt/ibm/notes/notes from a terminal / command line and provide the output when it crashes? 

Dec 22, 2013 8:49 PM
7 Posts
found the issue

Well, 

It seems that the issue is related more to GTK and your theme.. You can resolve this by doing the following: 

GTK2_RC_FILES=""

 

Prior to launching notes. This fixed the sending mail issue I had while using the oxygen theme. 

I've tested it with Plastique which didn't seem to have the same problems sending emails. 

 

### UPDATE ###

I was able to get it working just fine with oxygen by upgrading to gtk2-themes-oxygen 1.4.1. Please see: 

http://www.freetechie.com/blog/using-lotus-notes-9-0-1-on-opensuse-13-1-gnome-libs-2-38-2/

 

Which I've updated accordingly. 

Dec 23, 2013 9:41 PM
4 Posts
Notes9 working now- but only after running it as root

Hi Ben,

Thank you for you interest and help.  The good news is that it's working now, but it was a strange experience:

I first exported GTK2_RC_FILES="" as you suggested, and this got rid of the two error messages referring to GTK2, but the behavior was the same- I got the splash screen, and then nothing- it just dies.  So next I added the two GTK2 packages, but this made no difference.

So I poked around the directory ~/lotus/notes/data/workspace/logs, and looked at error-log-0.xml, which contained this message along with others that seemed related:

2013-12-24T01:24:42.126-07:00    SEVERE    CWPIH0008E: An error occurred while attempting to save the plugin_customization.ini properties file.    com.ibm.rcp.installhandler.util

The only occurrences of that file I could find was in the install dir:

/opt/ibm/notes/framework/rcp/eclipse/plugins/com.ibm.rcp.base_9.0.1.20131002-1404/plugin_customization.ini
/opt/ibm/notes/framework/rcp/plugin_customization.ini
/opt/ibm/notes/framework/rcp/plugin_customization.ini.orig
/opt/ibm/notes/framework/shared/eclipse/features/com.ibm.collaboration.realtime.telephony.sut.blue.feature_8.5.2.20130925-0945/plugin_customization.ini

These are all owned by root and write-protected, so it seems strange that Notes is trying to update it while running under my userid.  On a lark, I ran Notes as root to see what would happen, and of course it failed with all kinds of console messages and a pop-up saying that I couldn't run that way.  

So I tried again, running /opt/ibm/notes/notes as my normal userid-  and this time it worked!  According to their timestamps, running as root touched several files in /opt/ibm/notes/framework/rcp/ including plugin_customization.ini (as it was want to do).

Any ideas or explanation for this? Did i miss an install step that running as root took care of?

Craig

Dec 30, 2013 2:54 PM
7 Posts
more info.

Craig, 

Yes... you never want to launch notes as root. That explains your issue. 

Although I still recommend upgrading to oxygen 1.4.1 if you're using KDE (and Oxygen) and there's an undefined symbol: g_type_add_instance_private in gvfs 1.18 which is included in openSUSE 13.1. 

I've confirmed that the gvfs module  libgioremote-volume-monitor from 1.14 still works fine for Lotus Notes, and now I'm able to open notes, send emails and download attachments. 

Jan 1, 2014 12:17 PM
4 Posts
running notes as root

Hi Ben,

Just to be clear and to explain my weird experience, I Don't run as root.  I only ran as root a single time after I noticed that Notes was trying to update plugin_customization.ini in /opt which is writable only by root.  I did this on a lark to see if updating the file would get further in the start up sequence, which it did.  This is not what should have happened, but the result was good.

 

 

Jan 2, 2014 11:59 PM
7 Posts
cbell response..

Craig, 

Yah, the sending is an issue with the oxygen-gtk theme.. I've changed themes for my GTK apps in KDE for now. 

Sep 9, 2014 7:39 AM
1 Posts
Same crash with Fedora 20 and KDE desktop

Changing gtk style from "oxygen-gtk" to "Bluebird" solved the problem.

I achieved this by opening System Settings -> Application Appearance -> Gtk+ Appearance