Oct 20, 2017 9:15 AM
46 Posts

TNEF Parse failed

  • Category: Domino Server
  • Platform: Windows
  • Release: 9.0.1
  • Role: Administrator,Developer
  • Tags:
  • Replies: 7

I am seeing this error in my server log - sometimes the TNEF conversion is successful, but sometimes it fails with this message:

10/20/2017 08:40:06 AM  TNEFConvert: ParseFile failed.
10/20/2017 08:40:06 AM  TNEFConvert: Encountered errors process message for xxx@acme.com

Google search does not give me anything on the error message. There are references to S/MIME issues with TNEF conversion - is that what this is about? 

Appreciate any ideas you might have. Server is 9.0.1 FP9

Oct 21, 2017 2:47 PM
8 Posts
Try these ini settings to get more information
TNEFConverter_Log_Level=40
TNEFDebug=1

After you see the error again, check the log.  It should contain log messages which include this string:

"
TNEFConvert (DEBUG):"

In particular, it may contain more detailed information about what went wrong.
Oct 22, 2017 2:44 PM
46 Posts
here is the result I get when 'debug' is turned on

 

10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): TNEFProcessNote called for handle 000000B6
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): Found file attachment winmail.dat...
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): Has a tnef file attachment named winmail.dat.
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): Target file name: c:\savtemp\notesEC4863\wm735164.dat
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): Skipping Message Attribute: attTnefVersion [00089006]
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): Attribute attTnefVersion [00089006] successfully added to attributes.
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): Processing Message Attribute: attOemCodepage [00069007]
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): Attribute attOemCodepage [00069007] successfully added to attributes.
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): Skipping Message Attribute: attMessageID [00018009]
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): Attribute attMessageID [00018009] successfully added to attributes.
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): Skipping Message Attribute: attPriority [0004800D]
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): Attribute attPriority [0004800D] successfully added to attributes.
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): Skipping Message Attribute: attDateSent [00038005]
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): Attribute attDateSent [00038005] successfully added to attributes.
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): Skipping Message Attribute: attDateModified [00038020]
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): Attribute attDateModified [00038020] successfully added to attributes.
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): Skipping Message Attribute: attRecipTable [00069004]
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): Attribute attRecipTable [00069004] successfully added to attributes.
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): Processing Message Attribute: attMAPIProps [00069003]
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): Attribute attMAPIProps [00069003] successfully added to attributes.
10/23/2017 09:02:13 AM  TNEFConvert (DEBUG): PT_INVALID_TNEF_FORMAT
10/23/2017 09:02:13 AM  TNEFConvert: ParseFile failed.
10/23/2017 09:02:13 AM  TNEFConvert: Encountered errors process message for xxx@acme.com

 

when googling the text 'PT_INVALID_TNEF_FORMAT', I find one person that says setting TNEFBreakSMIME=1 will help. does that make sense?

Oct 23, 2017 11:29 AM
8 Posts
This may be a corrupted TNEF stream
It's certainly a record sequence which is confusing the TNEF converter.  And no, on the face of it, it does not make sense that TNEFBreakSMIME=1 would fix this.

But please try it with debug still enabled and let's see what happens.
Oct 24, 2017 8:07 AM
46 Posts
no difference

Paul, you were correct, adding TNEFBreakSMIME=1 does not seem to have helped. I'm still getting  PT_INVALID_TNEF_FORMAT on some TNEF messages. Any suggestions?

Oct 26, 2017 2:51 PM
46 Posts
read receipts

examining the messages that failed TNEF conversion in the user mailboxes, they appear to be 'read receipts' in response to messages sent from our users to external email systems. the winmail.dat file is still attached because the conversion failed. is that a clue?

Oct 27, 2017 2:58 AM
8 Posts
It probably doesn't matter if the messages are read receipts
Please open an incident with support.  If you can share or more of the messages, that would be a big help in diagnosing this issue.