Apr 19, 2016, 4:08 PM
61 Posts

Error connecting to server Remote system no longer responding

  • Category: Domino Administrator
  • Platform: Windows
  • Release: 9.0.1
  • Role: Administrator
  • Tags: server,restore,9.0.1.FP4
  • Replies: 4

We do an annual Disaster Recovery test.  One of our Domino servers is part of this test.

After installation of the OS and other apps, Domino 9.0.1 is installed as well as the FixPack cyurrently on the production server.

We then install Backup Exec and restore "Lotus Notes Databases" from tape in \Data folder. We also restore the notes.ini

We do not restore any of the program files.

Since we upgraded to Win2008R2 and Domino 9.x about 3 years ago, when the server is started, an error appears in the console:

 "Error connecting to server MyNotesServer/Domain: Remote system no longer responding" which means it can't connect to itself.

I thought I had fixed this last year with by adding DNSServer=  to the notes.ini as well as adding the ip address and corresponding dns address to the hosts file.

However, last week, during the test, the error came up again, and this time I just let the server run as I searched Google again.

The error continuously repeated in the console for exactly 6 minutes and then it moves on and the server returns to normal.

I have no idea why it fixed itself, nor why it appears in the first place.

I welcome any suggestions (although I won't be able to test until next year).

 

Thanks,

Pam

Apr 21, 2016, 1:50 PM
10 Posts
Few places to check

I'd check few places:  OS server name, Net Address field in server's doc under Ports, hosts file (if used), and DNSServer= line.

My gut instinct says that Net Address and OS server name are not the same. Error comes up until server picks up DNS name.

Apr 22, 2016, 11:14 AM
2 Posts
basic network test

hi,

1/ did you try to ping your remote server ? If yes, did it work ? if no, check your network settings on each hosts to be sure they can communicate together.

2/ If 1) is ok, On your Domino console, try to run Trace command ? You should see if your Domino servers can communicate togheter, and display how Domino servers try to join each others, IP addresses are displayed and if session can be opened successfully.

If you notice then IP addresses displayed after tracing command are different than into you operating system, Check if you have any wrong connection document into your public directory ?

SP.

 

Apr 22, 2016, 1:53 PM
61 Posts
Possibly OS server name

Giedrius, you may be onto something.  Because this is a production server, and during Disaster Recovery testing we are restoring  the full domino server from tape, it could be that the OS name has the "wrong" Primary DNS suffix.

On the production server, it's in our WIndows domain, so it's DominoServer.AD_Domain.com

However, the original author of the operating system component of the script we use for Disaster Recovery has the correct computer name for the server, but has the Primary DNS suffix set to our company's Internet domain.

I'm going to make a note to change that setting during next years' test, and see if that error still occcur.

There is an entry in the hosts file on the recovered server that points to it's fully qualified internet host name (which is different than the server name) and it's correct IP.

And the DNSServer= line in the notes.ini is correct as well.

Apr 22, 2016, 3:20 PM
10 Posts
Suggestion

We also use AD. I never put FQDN in Domino server port configuration. I just use machine name without internet domain. So I have just DomServer instead of DomServer.AD.local. This way server has to resolve only the host it's running on without using DNS.

I've never had any issues by setting it this way. Hopefully it helps.