This forum is closed to new posts and responses. New discussions are now taking place in the IBM Developer Answers forum.


Mar 29, 2017, 2:00 PM
329 Posts

Here's a puzzler - 'File does not exist Pernames.ntf'

  • Category: Notes Client
  • Platform: Windows
  • Release: 9.0.1
  • Role: Administrator,End User
  • Tags:
  • Replies: 17

Over the last few days, we've had 3 or 4 occurrences of an issue I've not seen in (all) my 18 years....

Client is happily humming along in their Notes client, then (it was reported) the client 'just closes' <still not sure what exactly happens>.

The user reopens the client and is prompted to enter their name & Notes server - the standard set up dialog. After their password is entered they receive another pop-up stating: ' File does not exist Pernames.ntf'.

I found nothing by searching for 'pernames.ntf' other than a couple older hits from Notes 6.5x days...

The first couple times that we saw this, it appeared that the client's notes.ini was intact, clearing all but the first two lines & trying to set the client up again didn't help - the only recourse was to completely uninstall & re-install Notes. 

However, the last two times this happened (today) I noticed that the Notes.ini line: 'Directory=c:\Program Files (x86)\IBM\Notes\Data' had been changed to 'Directory=c:\Program Files (x86)\IBM\Notes' - so now the error message describes the error perfectly. It was just never noticed the first couple times.

I'm not 100% sure if the notes.ini 'directory' change is happening before the user sees an issue, or if it's somehow being set during the subsequent recovery process.

This has happened to 4 different users, running Notes9.0, or 9.0.1FP3. All on a 9.0.1FP6 server. No NSDs. I haven't seen anything odd in the console logs...

Has anyone ever seen anything like this? Any ideas?

As far as I know, the 4 issues in the past couple days is the first this has ever happened, but too many times now to write it off as a coincidence...

Mar 29, 2017, 4:34 PM
326 Posts
Ideas

Once the client crashes it seems that it lost the path to the notes.ini    Now some questions

is the ini  in a roaming  profile? Is there a nas issue with that drive?

 

My guess the reason the client is creating the ini in the wrong directory is

1) the start in for the icon is set wrong

or

 

2) check the reg keys "HKEY_CURRENT_USER\SOFTWARE\Lotus\Notes\NotesIniPath"  and make sure that is correct and the sub keys for notes 9 is correct. 

 

This will fix the issue of file does not exist.  But I would get the os/nas folks involved with thy is the directory  disconnecting

Mar 29, 2017, 7:48 PM
329 Posts
Not roaming..

Thanks for the reply, Barry!

My thoughts exactly, (that it lost sight of the notes.ini) so early on i suspected a registry entry, but by the time I was involved there had been a number of 'normal troubleshooting / recovery' things done, so we just reloaded the client. They both needed upgrading to FP6 anyway, so no harm no foul...  But I did get involved early in the last two issues and found that the notes.ini 'Directory' had been changed.

Once the client tried to start, it actually created some files in ' c:\Program Files (x86)\IBM\Notes' - and had created the IBM_TECHNICAL_SUPPORT folder there as well. But there were no crashes to be found.

Not a roaming profile, we don't do that.

I just checked MY registry - I'm running 9.0.1FP6 Admin/Designer - I don't see ' HKEY_CURRENT_USER\SOFTWARE\Lotus\Notes\NotesIniPath' - in fact I don't see 'NotesIniPath', nor 'NotesIni'.

I'll have to do some more poking around...

 

Mar 29, 2017, 9:54 PM
326 Posts
OOPs

Check HKEY_CURRENT_USER\SOFTWARE\IBM\Notes\NotesIniPath

 

Where these upgrades from notes 8.x or new installs.   In the past we did uninstalls and then a install.

Mar 30, 2017, 1:28 PM
212 Posts
problem with path

You can try to re-install the client on the users workstation.  If you un-install it first, then re-install, it will insure that the regestry settings are correct.

Mar 30, 2017, 1:28 PM
212 Posts
problem with path

You can try to re-install the client on the users workstation.  If you un-install it first, then re-install, it will insure that the regestry settings are correct.

Mar 31, 2017, 11:59 AM
196 Posts
Pernames.ntf

Pernames.ntf is used to create the Contacts.  The name of the template reflects the eariler name, which was Personal Address Book. Are you not finding pernames.ntf in the data directory of your Notes installations?  If so, was an installation package developed in-house to set up the Notes clients?

Apr 5, 2017, 9:43 AM
329 Posts
Notes.ini change...

The pernames.ntf is always found in the data directory, that's what was puzzling at first.

No, these are standard IBM Notes installs, using the IBM install package.

This issue, as I tried to describe it, is that upon restart of the client, the Notes.ini line: 'Directory=c:\Program Files (x86)\IBM\Notes\Data' had been changed to 'Directory=c:\Program Files (x86)\IBM\Notes'  - the pernames.ntf file is NOT found there, nor does Notes work.

Changing the Notes.ini parm back fixes the issue - the question is - why does the notes.ini line get changed, and by whom?

When it happened the first time, it was odd, but we dismissed it. The 4th time, to a 4th user, seems like some kind of pattern.

Apr 5, 2017, 9:43 AM
329 Posts
(Duplicate post) Notes.ini change...

<duplicate post deleted>

Never had a post duplicated before - I've heard it was just users with IE - I'm running Firefox...

...gonna be another long day...

Apr 6, 2017, 3:10 PM
329 Posts
Registry Entries

So - we just had another occurrence today... the Notes.ini line: 'Directory=c:\Program Files (x86)\IBM\Notes\Data' had been changed to 'Directory=c:\Program Files (x86)\IBM\Notes'  - and the user receives the ' File does not exist Pernames.ntf'. This was on 9.0.1FP3.

I'm having the Helpdesk completely uninstall, run NICE, and reinstall 9.0.1FP6.

We checked the registry, still do not find ' NotesIniPath' - but do find the following:

HKEY_CURRENT_USER\SOFTWARE\IBM\Notes\Installer\DATADIR

HKEY_CURRENT_USER\SOFTWARE\IBM\Notes\Installer\DirectoryValue

HKEY_CURRENT_USER\SOFTWARE\IBM\Notes\Installer\NOTESDATAPATH

.. which all contain the value:  c:\Program Files (x86)\IBM\Notes\Data\

HKEY_CURRENT_USER\SOFTWARE\IBM\Notes\Installer\PROGDIR contains the value: C:\Program Files (x86)\IBM\Notes\

 

Apr 6, 2017, 4:17 PM
326 Posts
Question

What windows Version

Was this an upgrade or new install.

Is it a multiuser install.   If so the templates are in a common directory and not in the data directory

Apr 7, 2017, 10:31 AM
329 Posts
Windows 7

Most client installs are Windows 7, 64bit.. Installs have traditionally been single user installs, however we have some that are multiuser. I do not believe I've seen a multiuser install exhibit this behavior.

Calls go thru a helpdesk first, so I only was involved once this became a repeat issue. The PCs that I've looked at have been Windows 7 64 bit.

The installs (that I've seen) have all clearly been single user installs, all the templates & databases are in ' c:\Program Files (x86)\IBM\Notes\Data ', the users mail file replica is located in ' c:\Program Files (x86)\IBM\Notes\Data\mail ', the console.log & other log files are located at ' c:\Program Files (x86)\IBM\Notes\Data\IBM_TECHNICAL_SUPPORT 'etc - all as they should be... No files in the Users\AppData directory...

But after the notes.ini change & subsequent restart of the client, various files get created in the notes program directory, and the directory 'c:\Program Files (x86)\IBM\Notes\IBM_TECHNICAL_SUPPORT' gets created.

 

Apr 7, 2017, 11:24 AM
326 Posts
old intalls

when you show program files(x86) so why are they installing a 32 on a 64 machine?    I would go with using NICE to clear out prior installs.   check reg for no remaining regkeys and install 64 on 64 machine.   This still does not fix the question of why the notes.ini is disappearing but at least you will have the correct version on the  correct os.

 

I also want to point out that I have seen strange issues with virus scan,   Can you eliminate on access to the data directory/notes program directory?

Apr 7, 2017, 4:11 PM
329 Posts
64 bit?

I wasn't aware that there was a 64 bit client for Notes! I'll have to start digging thru Passport again..

I have thought about the virus scanner before, but I keep getting shot down. I'll bring it up again!

Thanks!

 

Apr 7, 2017, 4:34 PM
326 Posts
oops

Got confused.  64 only mac.  No 64 for windows

Apr 7, 2017, 5:10 PM
329 Posts
Nards!

Then there's the fix! Dump Windows and get a Mac for everyone!!

;-)

I had the SEP guy make sure that both the Notes program and data directory are excluded. I guess we'll see what happens next!

Thanks, Barry!

Apr 28, 2017, 9:06 AM
329 Posts
Hierarchical name length ??

It's still happening - we see it at least a couple times a week.

But it appears that it's only happening for users in 2 specific locations. each location has its own server, so I can't narrow it down to a server - but, since both are in the same city, both locations are using longer hierarchical names than before. As I do a quick count, most old names were below 50 characters, the same user's new hierarchical name might be 69 characters or slightly longer.

The Admin guide indicates the maximum name length is 79 characters, and we're below that, but this seems awful coincidental.

And the fact that the Autosave feature has been broken due to user name length until FP6 seems suspicious also!

 


This forum is closed to new posts and responses. New discussions are now taking place in the IBM Developer Answers forum.