FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.


Jan 14, 2015, 3:57 PM
31 Posts

Database Locked

  • Category: Domino Server
  • Platform: Windows
  • Release: 9.0.1
  • Role:
  • Tags:
  • Replies: 14

We are having intermittent issues with several of our databases locking up.  These databases are used to store deleted documents from our primary application databases.  

When this happens:

- LotusScript agents fail when trying to reference the database (from another database in this case), with an error of  "Unable to open Name and Address Book (%s), due to error '%e'".

- The Notes Client cannot open the database

- Fixup will not run on the database.  "This database is currently in use by another person or process, and cannot be accessed at this time."

- Windows ProcessMon reports handles to the database by nserver.exe and nclrepl.exe when this is happening.  No other databases show the cluster replicator with a handle.  Seems like a lock by the cluster replicator.

- The server does not run anit-virus software, and as stated above - no other software has a handle on the file.

Any ideas or thoughts on how to track this down?

Matt

 

Jan 15, 2015, 1:39 PM
26 Posts
post your code

Could be the way your agen is trying to open or write to the database.

Jan 15, 2015, 1:39 PM
26 Posts
post your code

Could be the way your agen is trying to open or write to the database.

Jan 16, 2015, 9:27 AM
59 Posts
maybe this will help?

If the database is in use by something in Notes, try the Domino Administrator to see who has the database open (server tab>database users). you can also force the users to let go of the database by right-clicking on the database name and choosing 'drop'.

Hope that helps!

Jan 18, 2015, 2:02 PM
31 Posts
Solutions Tried

The only way to unlock the database is a full server reboot.

We have tried these, without success:

  • "restart server"
  • "drop all"
  • Restart cluster replicator
  • "dbcache flush"
  • "load fixup"

We had 2 cluster replicators, but we are trying it with 1 to see if that prevents future locks.

 

Jan 22, 2015, 11:03 AM
59 Posts
FP3

hey....did you see this from the 9.0.1 FP3 release notes?

 

  • JPAI9CTMWE (LO82330) - Fixed an intermittent issue that would cause a single Notes database to be locked preventing anyone from opening the database until the Domino server is restarted. Before this fix, users would experience the following error attempting to open the database: "This database is currently in use by another person or process, and cannot be accessed at this time. In order to share a Notes database, it must be accessed via a Domino Server by all users of the database.”
Jan 27, 2015, 12:41 PM
31 Posts
Thanks Stuart

Thanks Stuart.   That sounds like the fix.  I'll give it a try.

Nov 25, 2015, 8:53 AM
1 Posts
Same problem here

It's very nice to see we are not alone with this problem. We hate this problem since 9.0.1,

IBM Tell us FP2 will solve the problem, problem still present
IBM Tell us FP2HF* will solve the problem, problem still present
IBM Tell us FP3 will solve the problem, problem still present

And so on !

We are currently running with FP4HF523 and the problem is still there.

We have a cluster of 4 serveurs with 6000+ mailfile on each of them... each days, all serveurs choose randomly 1,2,3 or more database to lock.

On my side, 99% of the time, if I run on the console "tell clrepl quit" followed by "load clrepl" to restart the cluster replicator, it solve the problem !

 

I hope this will be solve in 2016 !

JFLegendre

Feb 2, 2016, 12:11 AM
31 Posts
9.0.1FP5 - Still have this periodic locking issue

I'm losing faith that this will be resolve.  Any other way to unlock the database with out rebooting?

Aug 29, 2016, 7:50 PM
31 Posts
Updates

Hi Jean-Francios,

I used your fix today "tell clrepl quit" followed by "load clrepl" and it works.  Thanks!

Have you been able to resolve this 100% with any new hotfixes?

Matt

Mar 29, 2017, 7:37 PM
19 Posts
Most likely fixed in 9.0.1 FP8: SPR # MKIN9Z6S5D
    SPR Release Date modified Description
92%   MKIN9Z6S5D 9.0.1 FP8 03/03/2017 Fix an intermittent database issue preventing users from opening a database resulting in the following error "This database is currently in use by...

http://www-10.lotus.com/ldd/fixlist.nsf/5c087391999d06e7852569280062619d/556a8b1af86627ee852580d800738c71?OpenDocument&Highlight=0,MKIN9Z6S5D%20


Crucial tools for IBM Lotus Notes and Domino administration and development...

Find the "crucial tools you need to succeed" including product descriptions, downloads, demos and testimonials.
Speed up IBM Lotus Notes and Domino administration and development with these crucial software tools.
Better, stronger, faster productivity for administrators and developers.
Download and try the lite (free) version

 

Aug 24, 2017, 3:02 PM
31 Posts
FP8 did not solve this issue

I am still having this problem occasionally, due to a lock by the cluster replicator.


FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.