FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.


Nov 7, 2017, 10:09 AM
3 Posts

Server crashes during local archiving

  • Category: Domino Server
  • Platform: Windows
  • Release: 9.0.1
  • Role: Administrator,Developer
  • Tags:
  • Replies: 1

dear experts,

Recently, i found two mailboxes where the end user, when trying to archive locally, repeatedly manages to crash the whole server.

Part of the nsd log where it seems to go wrong:

@[ 9] 0x7FEF6F7D217 nnotes.Panic+1047 (0,12581D10030C77A,ce0eec8,0)
@[10] 0x7FEF6F83B1C nnotes.LockHandleExt+284 (0,ce0efb9,88e,7FEF7D9A088)
@[11] 0x7FEF6F83E12 nnotes.OSMemGetFaultHandleExt+34 (0,7FEF8F37DE0,7FEF8F37D10,1229d138)
@[12] 0x7FEF77395BC nnotes.OSLockPoolWithStatus+76 (ce0ef98,0,0,ce0f118)
@[13] 0x7FEF773A21E nnotes.OSLockPool+30 (ce0ef98,0,ce0f0f8,0)
@[14] 0x7FEF7D8CB8D nnotes.NSFNoteGetCreateDate+413 (0,be2f028,34,be23728)
@[15] 0x7FEF78387CB nnotes.CArchSetPolicy::FindArchiveCandidate+1675 (59912a90,0,0,0)
@[16] 0x7FEF7E5BF91 nnotes.DbSelectDocsForArchiving+1153 (0,88e,905,88e)
@[17] 0x7FEF78699CC nnotes.DbGetArchiveNotes+76 (88e,200000000,4b6d560,0)
@[18] 0x7FEF7869B13 nnotes.NSFDbGetArchiveNotesExt3+115 (0,ce0f6e0,0,7FEF8320000)
@[19] 0x7FEF1AF0F88 nserverl.ServerDbGetArchiveNotes+568 (506f0e18,5e900002,5e900007,ce0f910)
@[20] 0x7FEF1ABD854 nserverl.DbServer+3380 (ba820058,8fe80009,0,5e900002)
@[21] 0x7FEF1AD85D7 nserverl.WorkThreadTask+1847 (ba67000a,5a9c420,ce00000,ba820058)
@[22] 0x7FEF1A91AD9 nserverl.Scheduler+921 (a4a6b8,ba67000a,5a9d190,7311348)
@[23] 0x7FEF6F8D782 nnotes.ThreadWrapper+258 (0,0,0,0)
 [24] 0x774859cd kernel32.BaseThreadInitThunk+13 (0,0,0,0)
 [25] 0x775ba561 ntdll.RtlUserThreadStart+33 (0,0,0,0)

nfixup didn't find corrupted documents in the database and ncompact -c didn't solve the behavior either. When browsing through the All Document view, i couldn't find any weird values at the document properties  'created' and 'modified'.

Could anybody give me a hint about where to search for a solution?

From a replica of the database on a test server, archiving didn't give any problem. Both servers are running Domino 9.0.1 FP9

Thanks,

Roel

Nov 7, 2017, 3:20 PM
145 Posts
Call support and ask for a HotFix for you server for SPR PMGYAMDCQX
Looks like it will be fixed in 9.0.1 FP10 when it is released...

jpaganet@us.ibm.com

FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.