FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.


Feb 5, 2018, 6:18 AM
1 Posts

FP8-FP9-F10 vs. Document Encrypt

  • Category: Domino Designer
  • Platform: All Platforms
  • Release: 9.0.1
  • Role: Administrator,Developer
  • Tags: FP8,FP9,FP10,encrypt
  • Replies: 0

From 9.0.1FP8 document encrypt method changed (I think because of xPages). If you compile a code that has a simple call to a LotusScript library class that contains document encryption, its problematic. 

Sample code (Script Library):

Public Class Encrypter
        Public doc As NotesDocument
        
        Dim session As NotesSession
        Dim currdb As NotesDatabase
        Set session = New NotesSession    
        Set currdb = session.CurrentDatabase
        Set doc = New NotesDocument(currdb)
        Call doc.Encrypt
End Class


If you compile it with any Domino Designer below 9.0.1FP8, it works for all clients.
If you compile it with 9.0.1FP8, FP9 or FP10 it works in FP8-FP9-FP10 client, but failed to load script library on all previous clients (Error Loading USE or USELSX module Encrypter).
According to documentation, in previous versions, it has no parameters, but now it works with 0,1,2 parameters. We tried every combination, but still not working.
 
https://www.ibm.com/support/knowledgecenter/en/SSVRGU_9.0.1/basic/H_ENCRYPT_METHOD.html


FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.