Jan 21, 2015, 10:45 AM
105 Posts

Mixed version environment question

  • Category: Domino Administrator
  • Platform: Windows
  • Release: 9.0.1
  • Role: Administrator,Developer,End User
  • Tags:
  • Replies: 4

We have a single server inside the firewall used for all of our production apps. The server and clients are 8.5.3.

We have a single 'portal' server outside the firewall used by a small set of our customers for read-only access to a few apps via a browser. This server is currently at 8.5.3. Mail isn't implemented on this server; customers log in, see dbs, view docs, and leave. The only admin tasks I perform on this server are to add new users and push new replicas onto the external box (which I do from my Notes client, not the admin client)

Because of POODLE, we're going to be upgrading our portal server to 9.0.1. We have no plan to upgrade our internal server (or clients).

I'm the developer and admin for both servers.

I don't intend to install the 9.0.x designer client on my system.

Do I need to install the 9.0.x admin client or can I just keep using my 8.5.3 version?

Any risks with either scenario?

Thanks for any tips or suggestions.

 

Doug

Jan 22, 2015, 1:18 PM
31 Posts
Thoughts
Hello Doug,

   My understanding of the POODLE bug is that it affects HTTP requests and not NRPC transactions.  And I am not aware of the admin client doing any HTTP requests or of using the admin client to access a web page. Therefore using either version and doing standard Admin client actions will be fine.

   Regards,
                    Mark
Jan 23, 2015, 10:43 AM
105 Posts
Thanks

My concern was that when I tried to touch the 9.0.x serve with the 8.5.2 admin client I'd get some kind of 'nope...not allowed to use that old thing on this shiny new server' alert.  I really don't do much on the portal side anyway; it just sits and runs so worst case I might have to issue commands on the portal from the server console.

Thanks.

Jan 23, 2015, 1:25 PM
310 Posts
I honestly think you'd be OK.

...at least for a Domino 9.0.1 server...

Actually, come to think of it, my Administrator Client PC IS still at 8.5.3FP2.

The only thing that I can think of where you might run into an issue is, if you were to set 'Create_R9_Databases=1' on the server, you would not be able to copy any database that had been converted to ODS 52 on your R8.5.x client and open it. If you did not set 'Create_R9_Databases=1' (for example, still used 'Create_R85_Databases=1') you should be in great shape.

Jan 24, 2015, 6:51 PM
212 Posts
Client upgrade questions

Since you are upgrading your server to 9.0.1, you should upgrade your Administration Client to 9.0.1 as well.  Both the 9.01 server and Admin Client will be backward compatible with the 8.5.3 servers.  You can sometimes see strange admin "Quirks" when trying to administer a 9.0 server with an 8.5.3 Admin Client.