FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.


Jul 23, 2016, 10:15 AM
362 Posts

I'm getting odd situations with the toolbar icons

  • Category: Application Development
  • Platform: Windows
  • Release: 9.0.1
  • Role: Administrator,Developer,End User
  • Tags: toolbar
  • Replies: 6

When I create a toolbar icon, it's as if its formula sticks. When I try to go back & modify the formula, it doesn't modify.

I restart Notes, and I get one opportunity to modify the formula. Sometimes. Then it sticks again.

It's getting annoying restarting Notes every time.

Originally I had made changes to this (Universal) toolbar from Designer. And Designer seems to be more consistent producing toolbar icons. But they don't seem to translate back into the Lotus Notes client, either.

I'll probably try some of the standard fixes, but users need the ability to customize & personalize our capabilities. It's all about doing your job well.

Jul 25, 2016, 7:58 AM
105 Posts
Is this new?

Is this something that you can like to a specific event (or version)?

Have you opened a call with IBM?

Jul 25, 2016, 7:58 AM
105 Posts
Is this new?

Is this something that you can like to a specific event (or version)?

Have you opened a call with IBM?

Jul 25, 2016, 9:53 AM
362 Posts
I've seen similar in 853, but not had the occasion to try it in 9.0.1

'til now.

I generally don't open support calls with IBM unless the corporate usership reports it.

Just for the record, 32-bit on Windows 10.

I run into it in debug situations. So my current strategy is to use what I've got 'til it gets annoying; shut down Designer, restart Notes. Within Notes itself, if I haven't created a toolbar icon in Designer, Notes seems to figure it out.

I've also set aside the original bookmark.nsf so Notes created another. I'm hoping that doesn't become a requirement: toolbar customizations are destroyed when the bookmark.nsf corrupts, and I've never found a nice way to copy them into a brand new bookmark.nsf

Jul 25, 2016, 12:23 PM
105 Posts
Some thoughts

If it only happens in debug and not in production, then it's annoying but not fatal.

If it happens in production and this is something you need to deploy, then a ticket to IBM is probably advisable.

If there's a way to roll out the function without using a toolbar icon, that might be something to have in your back pocket just in case.

Jul 25, 2016, 12:23 PM
105 Posts
Some thoughts

If it only happens in debug and not in production, then it's annoying but not fatal.

If it happens in production and this is something you need to deploy, then a ticket to IBM is probably advisable.

If there's a way to roll out the function without using a toolbar icon, that might be something to have in your back pocket just in case.

Jul 25, 2016, 4:31 PM
362 Posts
I'm gonna try a whole reinstall & see where I end up.

Never can tell what's been installed underneath Notes that may be messing with it.


FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.