FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.


Feb 28, 2017, 11:57 AM
155 Posts

"design replace failed" and "you are not authorized to perform that operation"

  • Category: Administration
  • Platform: All Platforms
  • Release: 9.0.1
  • Role: Administrator
  • Tags:
  • Replies: 5

We have a sharp help desk person who is rolling out a template change.  Instead of doing using remote to the persons computer she would like to do it from the admin client.  However when she tries File, Application, Replace Design she is getting:

"design replace failed" and "you are not authorized to perform that operation".

In the interest of just giving her enough authority to get her job done what do I need to do?

I do not want to grant her authority to an individuals database just long enough to do this and then revoke her authority.  That's just too much manual labor on my part and rather negates her work.

Feb 28, 2017, 12:17 PM
196 Posts
What about using Full Access Administration?

You would not have to add and then remove the person from access to a set of files if they are permitted to use Full Access Administration. Their access is also logged.

By the way, if the design is hidden, then even with full administrator access, a replace design will fail.

Feb 28, 2017, 2:34 PM
324 Posts
I assume a replica of the file is on a server?

If a replica is located on a server (which I assume it is, or she wouldn't be able to try from the Admin client) I believe that she could use the convert -u command to upgrade the database design.

You didn't mention whether these were mail files or not, but from what i've read (i have not tried this) it reportedly works on non-mail files as well.

The format of the command:

load convert -u mail\bob.nsf * dnawm901.ntf

where '*' is the name of the old template (or '*' for any) and 'dnawm901.ntf' is the file name of the new template.

 

Feb 28, 2017, 9:35 PM
320 Posts
Also

You can run the nconvert command from a pc that has a notes client installed.   Just open a command prompt and use nconvert -u SERVERNAME!!mail\bob.nsf * Servername!!dnawm901.ntf

Mar 1, 2017, 6:33 PM
196 Posts
Caution needed when using load convert with the -u switch on non-mail databases

load convert -u has unpredictable/undesirable consequences for non-mail databases.  A non-mail database is anything without an $Inbox.

Mar 2, 2017, 8:28 AM
324 Posts
Thanks, Jay!

That is good to know as I had not heard that before. But i've never tried it, either.


FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.