David A Batres commented on Oct 8, 2014

Re: A Step-By-Step Guide to Perform a Silent Installation of Portal v8.0

@Eamonn The warnings suggest all of the required parts were not extracted to the same directory. For example, if you downloaded all of the required parts for Portal 8.0 Express noted in the knowledge center, you would end up with a directory structure like:

/tmp/was-portal-server/Setup

/tmp/was-portal-server/WAS

/tmp/was-portal-server/Portal

/tmp/was-portal-server/...

Reference:

http://www-01.ibm.com/support/knowledgecenter/SSHRKX_8.0.0/dd/dd_express.dita?lang=en

Reason being, the repository.config file in Setup/eimage will have a relative reference to the other parts (e.g. Portal and WAS) and it expects them to be extracted into the same directory.

The error itself seems to be unable to find the response file that is included in the Setup part. Have you verified this file actually exists, and the user running the install has sufficient permissions to it?

/tmp/was-portal-server/Setup/responsefiles/express_standalone_install.xml

Note: Installation Manager will attempt to use the response file specified for the input parameter of the imcl command.

Eamonn J Killian commented on Aug 11, 2014

Re: A Step-By-Step Guide to Perform a Silent Installation of Portal v8.0

Hi there ... tried in vain for two weekends to get this working ... First I downloaded the agent* install for IIM and carried out a silent install of IIM = No problem it is installed and good to go ...

I have then downloaded Websphere Portal Server v8.0 from this address https://www14.software.ibm.com/webapp/iwm/web/reg/download.do?source=ESD-PORTALEXPRESS&S_PKG=CRJ46ML&S_TACT=109HD0SW&S_CMP=web_dw_rt_swd&lang=en_US&cp=UTF-8 and have configured the responsefile as outlined above ... the error I get is:

00:00.60 WARNING [main] com.ibm.cic.common.core.repository.CompositeRepository getGroup

Composite repository "/tmp/was-portal-server/Setup/eimage" could not access the referenced repository "/tmp/was-portal-server/WAS".

00:00.64 WARNING [main] com.ibm.cic.common.core.repository.CompositeRepository getGroup

Composite repository "/tmp/was-portal-server/Setup/eimage" could not access the referenced repository "/tmp/was-portal-server/Portal".

ERROR: The com.ibm.websphere.ND.v80 8.0.3.20120320_0536 package specified in the /tmp/was-portal-server/Setup/responsefiles/express_standalone_install.xml file cannot be found.

ERROR: The com.ibm.websphere.PORTAL.EXPRESS.v80 8.0.0.20120421_1028 package specified in the /tmp/was-portal-server/Setup/responsefiles/express_standalone_install.xml file cannot be found.

Any help greatly appreciated ...