Skip to main content
This forum is closed to new posts and responses. New discussions are now taking place in the IBM Developer Answers forum.
Information Mgmt
New to Lotus
How to buy
Live demos
Technical library
Forums & community
Java™ technology
Open source
SOA and Web services
Web development
My developerWorks
About dW
Submit content

developerWorks  >  Lotus  >  Forums & community  >  IBM Sametime Forum

IBM Sametime Forum



PreviousPrevious NextNext

Anders Aslund 26.Mar.15 10:28 AM a Web browser
Administration 9.0 Linux

OS: Ubuntu 14.04 LTS 64bit
Domino 9.0.1 installed and can run. No problems.

But Sametime 9 fail with error:
Bundled JRE is not binary compatible with host OS/Arch or it is corrupt. Testing bundled JRE failed.

Before installation I had do do some extra stuff to get to the error above. The Sametime-installed could not continue unless i set some soft links.

First installed this:
* sudo apt-get install gcc-multilib,lib32stdc++6 libxmu6:i386 libxp6:i386 libstdc++5:i386 libstdc++6:i386 lib32z1 lib32ncurses5 lib32bz2-1.0 libc6:i386 libncurses5:i386

Then did som some:
cd /usr/lib32
ln -s /usr/lib/i386-linux-gnu/
ln -s /usr/lib/i386-linux-gnu/
ln -s /usr/lib/i386-linux-gnu/
ln -s /usr/lib/i386-linux-gnu/

Then updated setuplinux.bin:
Replcated some "/usr/lib" with "/usr/lib32" (only on one row)

Still the installer ends with this error all the time:
Bundled JRE is not binary compatible with host OS/Arch or it is corrupt. Testing bundled JRE failed.

I have tried to use the installer for Sametime 9 Limited and the Sametime 9 ordinary installer. Both fail at same position.

Any ideas?

Installed default java
java -jar setup.jar -console
(instead of setuplinux.bin)

[Update 2]
I thought that I nailed it but the installer aborted after 10% saying that No JVM found. So back to basics.

The default JVM failes. So using the from Domino is a better idea:
PATH=/opt/ibm/domino/notes/latest/linux/jvm/bin:$PATH JAVA_HOME=/opt/ibm/dominootes/latest/linux/jvm java -jar setup.jar -console

[Update 3]
Instead of running the Sametime 9 installer.
Running the installer for the patch (which has a better setuplinux.bin).

This command will start the installer correctly:
STSkipOSCheck=true JAVA_COMPILER=NONE PATH=/opt/ibm/domino/notes/latest/linux/jvm:$PATH JAVA_HOME=/opt/ibm/domino/notes/latest/linux/jvm CLASSPATH=/opt/ibm/domino/notes/latest/linux/jvm LD_LIBRARY_PATH=/usr/lib/i386-linux-gnu/ ./setuplinux.bin -console

[Solved] Bundled JRE is not binary ... (Anders Aslund 26.Mar.15)
. . RE: [Solved] Bundled JRE is not bin... (Ben Williams 26.Mar.15)

  Document options
Print this pagePrint this page

 Search this forum

  Forum views and search
Date (threaded)
Date (flat)
With excerpt
Advanced search

 RSS feedsRSS
All forum posts RSS
All main topics RSS
More Lotus RSS feeds


Forum use and etiquette
Native Notes Access
Web site Feedback

Lotus Support

 Lotus Support
IBM Support Portal - Lotus software
Lotus Support documents
Lotus support by product
Lotus support downloads
Lotus support RSS feeds


IBM Composite Applications
IBM Mashup Center
IBM Connections
IBM Connections Cloud Developers
IBM Docs
IBM Forms
IBM Mobile Connect
IBM Sametime
IBM SmartCloud for Social Business
IBM Web Experience Factory
Lotus Domino
Lotus Domino Designer
Lotus Expeditor
Lotus Foundations
Lotus iNotes
Lotus Instructor Community Courseware
Lotus Notes
Lotus Notes & Domino Application Development
Lotus Notes Traveler
Lotus Protector
Lotus Quickr
Lotus Symphony
IBM Web Content Manager
WebSphere Portal

Lotus Forums

 Lotus Forums
Notes/Domino 9.0
Notes/Domino 8.5 + Traveler
Notes/Domino XPages development forum
Notes/Domino 8
Notes/Domino 6 and 7
IBM Connections
IBM Mobile Connect
IBM Sametime
IBM SmartCloud Notes
Lotus Enterprise Integration
Lotus Protector
Lotus Quickr
Lotus SmartSuite