Skip to main content
This forum is closed to new posts and responses. New discussions are now taking place in the IBM Developer Answers forum.
 
developerWorks
AIX and UNIX
Information Mgmt
Lotus
New to Lotus
Products
How to buy
Downloads
Live demos
Technical library
Training
Support
Forums & community
Events
Rational
Tivoli
WebSphere
Java™ technology
Linux
Open source
SOA and Web services
Web development
XML
My developerWorks
About dW
Submit content
Feedback



developerWorks  >  Lotus  >  Forums & community  >  IBM Sametime Forum

IBM Sametime Forum

developerWorks

  

PreviousPrevious NextNext


Anders Aslund 22.Sep.13 03:00 PM a Web browser
Server 9.0 Linux


I am trying to install Sametime 9 (Domino part) on OpenSuse 12.3 64-bit server.

I know it is not a supported configuration, it is just for testing.

1) I have installed Domino 9 server. It works fine.
2) Sametime installer complains on first start about a 3 32-bit libraries missing. I install them and the installer continue.
3) After selecting langue and a few steps the installer hangs on accepting EULA. It does not really freeze, just cannot get further.

I cannot find any logs or anything, I have searched the whole filesystem after some logs that can show me what is the problem but I cannot find them. No SametimeInstall.log or similar neither in /tmp or /local/notesdata

Does anybody know any debug-parameters for setuplinux.bin or similar?

I have tried silentinstall with option-linux.txt. But this one just stops after 15 seconds coming back to bash and there is no log files.
community:/opt/Install9/Sametime/SametimeStandardServer/Server # ./setuplinux.bin -console -silent -options options-unix.txt

WARNING: Unable to check requirements for this SuSE release (12.3 0).
Installation will proceed, but may not be successful.

./setuplinux.bin: line 2061: warning: here-document at line 2061 delimited by end-of-file (wanted `/dev/null')
community:/opt/Install9/Sametime/SametimeStandardServer/Server #



I had exactly the same issues earlier with Sametime 8.5.1 and 8.5.2 on OpenSuse, but then I tried Ubuntu Server and the installer worked better.

Any help?


[Update]
I got a bit furhter by disabling everything IPV6:
echo net.ipv6.conf.all.disable_ipv6=1 > /etc/sysctl.d/disableipv6.conf

But installer "hangs" at a later question in the install process.


[Update 2]
By looking into setuplinux.bin I found a debug parameter:
-is:log /tmp/installog.txt
./setuplinux.bin -console -silent -options options-unix.txt -is:log /tmp/installog.txt

This is the output:
cat /tmp/installog.txt
Log file created by MultiPlatform installer @Sun Sep 22 21:34:46 CEST 2013
INSTALLER_PATH=/opt/Install9/Sametime/SametimeStandardServer/Server/./setuplinux.bin
Checking the environment variables specifed in the JVM files to find the JVM...
No JVM can be found using the shell environment variable. Searching JVM will continue with Path Hints specified in the JVM Files...
jvm files not specified. Searching a JVM can not be performed.
Extracting bundled JRE...
disk space checking turned off/skipped.
disk space checking turned off/skipped.
installing bundled JRE...
Verifying... /tmp/istemp7445265213446/_bundledJRE_/bin/java -cp /tmp/istemp7445265213446/Verify.jar Verify java.vendor java.version
Verification passed for /tmp/istemp7445265213446/_bundledJRE_ using the JVM file /tmp/istemp7445265213446/_bundledJRE_/jvm.
-cp:p operand is empty
-cp:a operand is empty
Installer JAR archive is not embedded.
extracting embedded jars in the archive.
disk space checking turned off/skipped.
extracting embedded jars in the archive.
disk space checking turned off/skipped.
extracting embedded jars in the archive.
disk space checking turned off/skipped.
extracting embedded jars in the archive.
disk space checking turned off/skipped.
extracting embedded jars in the archive.
disk space checking turned off/skipped.
extracting embedded jars in the archive.
disk space checking turned off/skipped.
Run time Java arguments are not specified.
Java argument INIT_JAVA_HEAP is not defined in the JVM file /tmp/istemp7445265213446/_bundledJRE_/jvm.
Java argument MAX_JAVA_HEAP is not defined in the JVM file /tmp/istemp7445265213446/_bundledJRE_/jvm.
setting up prelaunch environment
LAUNCH_COMMAND="/tmp/istemp7445265213446/_bundledJRE_/bin/java" -cp .:::::"./setup.jar":::"/tmp/istemp7445265213446/ant-nodeps.jar":"/tmp/istemp7445265213446/STCore.jar":"/tmp/istemp7445265213446/Notes.jar":"/tmp/istemp7445265213446/stinstallutils.jar":"/tmp/istemp7445265213446/consoleDepClient14.jar":"/tmp/istemp7445265213446/commons-codec-1.3.jar":::: -Dtemp.dir="/tmp" -Dis.jvm.home="/tmp/istemp7445265213446/_bundledJRE_" -Dis.jvm.temp="1" -Dis.media.home="" -Dis.launcher.file="/opt/Install9/Sametime/SametimeStandardServer/Server/./setuplinux.bin" -Dis.jvm.file="/tmp/istemp7445265213446/_bundledJRE_/jvm" -Dis.external.home="/opt/Install9/Sametime/SametimeStandardServer/Server/." run "-console" "-silent" "-options" "options-unix.txt" 1>&1 2>>/tmp/istemp7445265213446/APP_STDERR

[Update 3]
I increased memory to 3GB (from 1GB) and installer installed Sametime!!!


Installing IBM Sametime Server 9.0. Please wait...

0 % complete
10 % complete
20 % complete
30 % complete
40 % complete
50 % complete
60 % complete
70 % complete
80 % complete
90 % complete
100 % complete
relativeUrlFormat : /console/deployment/getAnonTokenSecret
Finished writing shared secret


Creating uninstaller...


Finalizing the Vital Product Data Registry. Please wait...

IBM Sametime Server 9.0

The InstallShield Wizard has successfully installed IBM Sametime Server 9.0.
Choose Finish to exit the wizard.

Press 3 to Finish or 5 to Redisplay [3]




(So on OpenSuse the amount of memory is important, I did not have this issue when installing on Ubuntu server with exact same configuration)








  Document options
Print this pagePrint this page

 Search this forum

  Forum views and search
Date (threaded)
Date (flat)
With excerpt
Author
Category
Platform
Release
Advanced search

 RSS feedsRSS
All forum posts RSS
All main topics RSS
More Lotus RSS feeds

Resources

 Resources
Forum use and etiquette
Native Notes Access
Web site Feedback

Lotus Support

 Lotus Support
IBM Support Portal - Lotus software
Lotus Support documents
Lotus support by product
Lotus support downloads
Lotus support RSS feeds

Wikis

 Wikis
IBM Composite Applications
IBM Mashup Center
IBM Connections
IBM Connections Cloud Developers
IBM Docs
IBM Forms
IBM Mobile Connect
IBM Sametime
IBM SmartCloud for Social Business
IBM Web Experience Factory
Lotus Domino
Lotus Domino Designer
Lotus Expeditor
Lotus Foundations
Lotus iNotes
Lotus Instructor Community Courseware
Lotus Notes
Lotus Notes & Domino Application Development
Lotus Notes Traveler
Lotus Protector
Lotus Quickr
Lotus Symphony
IBM Web Content Manager
WebSphere Portal

Lotus Forums


 Lotus Forums
Notes/Domino 9.0
Notes/Domino 8.5 + Traveler
Notes/Domino XPages development forum
Notes/Domino 8
Notes/Domino 6 and 7
IBM Connections
IBM Mobile Connect
IBM Sametime
IBM SmartCloud Notes
Lotus Enterprise Integration
Lotus Protector
Lotus Quickr
Lotus SmartSuite