developerWorks  >  Lotus  >  Forums & community  >  IBM Sametime Forum

IBM Sametime Forum

developerWorks




DWA-Sametime: Applet STLinkAPP NOTINITED
Marius Punczi 10/13/2009 12:32 PM
Sametime Entry 8.0.1 Windows


Hallo All,

first the Config:

2 Dominoservers with Domino 7.0.3 FP1 (German LP)
Both are located in the DMZ.

1 Server is the DWA Server
1 Server is the sametime-server (8.0.1 - Entry)

Both are reachable from web.
With Notes-Client the connect to the sametime works - internal and external.

Implemented SSO-Ltpa Token for authentication. Web-View (no site-documents)

Did all steps for implementing sametime in dwa 7.x.

DWA 7.x template.

IM-Button displayed - but canĀ“t switch to online.

Additional tasks:
Entered the FQHN at STAdmin (webinterface)
Entered the FQHN in Hostinfo.xml

Seems to be no client prob: tested with site www.instant-tech.com. StLinkAPP loaded.

--------------------------------------------------------------------
Problem:
Statusbar in IExplorer displays:
Applet STLINKAPP NOTINITED

Log from the Java-Console:
load: class com.lotus.sametime.stlinks.client.STLinksApplet.class not found.
java.lang.ClassNotFoundException: com.lotus.sametime.stlinks.client.STLinksApplet.class
at sun.applet.AppletClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.applet.AppletClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.applet.AppletClassLoader.loadCode(Unknown Source)
at sun.applet.AppletPanel.createApplet(Unknown Source)
at sun.plugin.AppletViewer.createApplet(Unknown Source)
at sun.applet.AppletPanel.runLoader(Unknown Source)
at sun.applet.AppletPanel.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Dump classloader list ...
codebase=https://server.dom.at/sametime/stlinks/, key=https://server.dom.at/sametime/stlinks/,stlinks.jar, zombie=false, cache=true, refcount=1, info=sun.plugin.ClassLoaderInfo@7e5619

Dump thread list ...
Group main,ac=12,agc=2,pri=10
AWT-Windows,6,alive,daemon
traceMsgQueueThread,5,alive,daemon
CacheMemoryCleanUpThread,5,alive
CacheCleanUpThread,5,alive,daemon
Thread-67,5,alive
AWT-Shutdown,5,alive
AWT-EventQueue-0,6,alive
Group Plugin Thread Group,ac=3,agc=0,pri=10
TimerQueue,5,alive,daemon
AWT-EventQueue-1,6,alive
ConsoleWriterThread,6,alive,daemon
Group https:/sametime/stlinks/-threadGroup,ac=2,agc=0,pri=4
AWT-EventQueue-13,4,alive
thread applet-com.lotus.sametime.stlinks.client.STLinksApplet.class,4,alive
Done.
----------------------------------------------------
How can I check SSO-Lpta Token is working, without building an application?

Used both STLinks loaded from application-server and ST-Server. same result.

Is https the problem? sametime-server only http activated.

Ideas welcome. Many thanks in advance.
Regards

Go back