REMINDER:
On December 1, 2018, this forum will be closed to new posts and responses. After that date, you will still be able to view and search the forum. New discussions should take place in the IBM Developer Answers forum.



Apr 13, 2016, 9:57 AM
2 Posts

Access $VIMPeople View successful after opening the view in names.nsf in the Browser

  • Category: Server Side JavaScript
  • Platform: Linux
  • Release: 9.0.1
  • Role: Administrator,Developer
  • Tags:
  • Replies: 2

Hi everybody,

i have a Problem in here which is really strange. I can't understand it.
There is no Message in the log or in the Live Log.

My Code:
var db = new Array(@DbName()[0], "names.nsf");
var shownames = @DbColumn(db, "($VIMPeople)", 1);
@Name("[CN]", shownames);

didn't worked. The combox with this code was empty.
Empty for days...

Today i tried to open the View in the Browser. That worked perfectly.
Since this opening in the Browser my combox gets the values from ($VIMPeople) back and the combobox is useable.

Other users, other machines and other browser can now display the values.

So it seems that the Values are only accessable when you first open the View in a Browser Window.

I can't understand it. Do you?

There is no config change or anything...

Perhaps you have any idea.

 

Regards,
Sebi
 

Apr 13, 2016, 11:28 AM
26 Posts
Are you authenticated?
When you access the names.nsf view directly in the browser, you will be prompted for name and password, so you will be authenticated when you then load the form with the picker.  If you are going directly to the form and it isn't working, it's probably because you are not authenticated, and therefore don't have permission to access the names.nsf
Apr 13, 2016, 3:33 PM
2 Posts
I am authenticated

yep iam authenticated. When i access my xpage Application its need to authenticate first.

When i access the names.nsf its not need to authenticate again, so i am sure that i am authenticated.

 

Regards,
Sebi


REMINDER:
On December 1, 2018, this forum will be closed to new posts and responses. After that date, you will still be able to view and search the forum. New discussions should take place in the IBM Developer Answers forum.