Nov 16, 2011 12:25 PM
64 Posts

Xpages App XSP files do not load, HTML files do

  • Category: Debugging
  • Platform: Windows
  • Release: 8.5.1
  • Role: Developer
  • Tags: WebContent,XPages
  • Replies: 4
Greetings!
 
I am troubleshooting an issue with a Web App deployed to one our servers that loads straight/static HTML pages fine, but does not load Xpages.  The folder was newly created to testing on that server, and is web-enabled... not sure if something else needs to occur for XSP code to load normally.
 
Has this been reported as an issue? 
 
Köll 
Nov 16, 2011 1:34 PM
64 Posts
Re: Xpages App XSP files do not load, HTML files do (Update)
  • When the test server copy of the App is brought down, I check to see if all items were delivered to it, everything is present, HTML pages and so on, but the App does not load in the browser
  • I walked over to our server folks to see how the App is installed (Shipped), and what I found is that, in shipping/installing the App to the test server, two things have to go through,
             (1)ship/install it to an inward-facing server template that then creates a version of that App in the same directory,

             (2)then replace the same App on the outward-facing server based on coordinates from the inward-facing server copy of that App 

Here's where I think it broke, just not sure how to fix it:
  1. the inward-facing test server has every file showing in the Elements Window of DDE, which means in the Application Navigator area, where one would find Forms, Views, XPages, etc..., you can see + signs signifying there are files there for Forms, Views, XPages, etc...,
  2. but on the outward-facing server, there are no plus signs, it's as if there isn't even an App there, no files
  3. If you copy the App from the outward-facing server as a local App, and look inside, all files are available, attempt to run them throws a Web Page Unavailable   
Nov 18, 2011 1:54 AM
129 Posts
Re: Xpages App XSP files do not load, HTML files do
Just in case..
 
Do you have access to create (Designer)/run code on the server? 
Is the server running Domino 8.5.x?
Have you tried building the project after it's deployed? You could also try Project->Clean
Nov 22, 2011 1:50 PM
64 Posts
Re: Xpages App XSP files do not load, HTML files do
Greetings Tommy, thanks for replying... Yes, the Admins are building after the shipment of files to the Server, before firing the App...  although I don't think they've ever tried cleaning it.  Let me have them try that...  I am surprised the HTM pages load okay and not the Xpages.
 
I do have permission to the dev server, Admins have to throw the files onto test for us.
 
In a  bit! 
Mar 3, 2012 11:24 PM
64 Posts
Re: Xpages App XSP files do not load, HTML files do
Added Info:
 
Investigating this idea that perhaps the Admins who normally ship our Apps do not have full access to the Server in question; first time shipping Xpages to it...
 
Going this route, having re-read your response (Tommy), access to create!  There's a likelihood that it will work once a certain group that normally administers that server ships for us instead, will keep you posted...