FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.



Jan 19, 2016, 12:37 PM
1 Posts

$$ajaxid issue in Xpages

  • Category: Performance
  • Platform: Windows
  • Release: 8.5.3
  • Role:
  • Tags:
  • Replies: 1

Hi,

We get the below error from an xpage after one hour of execution (say button click and its running an excel report which takes more than 65 minutes to run) 

An error occurred while updating some of the page.
Unable to load /xxx/xxx/xxx/xxxx.nsf/xxxx.xsp?$$ajaxid=view%3A_id1%3A_id2%3A_id4%3xxxPanel status:12002

Kindly help!

Jan 19, 2016, 2:15 PM
453 Posts
XPages will time out automatically

a standard XPage will time out and the connection will be lost. If this is an issue there is a Stay Active control in the Extension Library that will regularly ping the server and thus keep the session active. I don't use that but have another process that does the same thing along with some other processes, but I'm guessing that this is probably your issue here. 

The session time out can be set on the XPages Properties, I believe by default it is 30 minutes but can be set to a longer time. Initially I had it set to 30 minutes and was working on a document composing a descriptive Rich Text field. I worked on it for about and hour or more then tried to save it and lost everything (I know I should have done incremental saves) but ..... It generally is only an issue when editing a document. There are a number of threads on StackoverFlow dealing with this issue as well as I think there is something on OpenNTF.

In any case I think this is your issue and it really probably is not exclusively related to the $$ajaxid but to the session time out.


FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.