Aug 20, 2014 7:54 PM
4 Posts

xPages install Extension Library - Domino Designer

  • Category: Extension Library
  • Platform: Linux
  • Release: 8.5.3
  • Role: Administrator,Developer
  • Tags:
  • Replies: 8

I am in the process of trying to install the xPages Extension Library in Domino Designer 8.5.3.

I created the updatesite nsf on our development site but failing when trying to link designer to it.  Here is the error when i try to install. 

Does anyone know how to resolve this?  Any help is appreciated. 

 

CWPPR0031W:  The request provisioning operation(s) completed with a partial success.

 

Network connection problems encountered during search:

Unable to access “https://domdevostx01.ten-net.net/updatesite.nsf”

Error parsing site stream. [White spaces are required between publicId and systemId.]

Aug 20, 2014 9:34 PM
366 Posts
Did you have designer open?

If so shut down designer, restart your notes client and try it again.

 

It's a well known bug that there is no fix for.

Aug 21, 2014 3:19 PM
4 Posts
Yes, several times.

Hey Paul.  Yes, I tried shutting down Designer and the Client many times but same issue.  Is there a certian Domino policy access that is required to do this?  Access rights is really restricted here at Bank of America.

Aug 21, 2014 3:40 PM
588 Posts
hmmm

I've no idea.  I would just suggest to make sure that you're running a version of the Ext. Library that's compatible with 8.5.3.  The more recent ones are for 9.0x I believe.

 

Just a thought.

Dave

Aug 21, 2014 4:25 PM
366 Posts
That's the error

you get when the site.xml can not be "read".

The url is https and that might be the problem.  can you access over straight http?

Aug 21, 2014 8:00 PM
4 Posts
That is the error

i get when in Designer I perform a File..Application..Install and then add "Remote Location".

 

The reason for https instead of http is because we have SSL configure on the server.

I got the extension library from here and i downloaded the 8.5.3 version from Apr 4th 2013(the newest one).  As you can see there are many releases of it for 8.5.3 so i am really not sure what the correct version i should be using.  Do you think i should use the most recent one as David suggested?

http://extlib.openntf.org/#main.nsf/project.xsp?r=project/XPages%20Extension%20Library/releases/9F11DD671408281386257D2600544A96&_suid=140866500768607065795735725391

Aug 21, 2014 10:11 PM
588 Posts
hmmm

That looks like the correct release.  I would also suggest you try pure http.  See if that makes s difference.  We have SSL on our server but I think I just use http for the updateSite stuff... 

Aug 22, 2014 12:27 PM
4 Posts
http

That did not work either.

I did notice however that my updatesite.nsf is missing 1 of the plugins from the "Import Local Update Site" that i performed to set up the DB in the first place.  Could this have something to do with it?

Aug 22, 2014 3:31 PM
588 Posts
hmm

I honestly don't know.  I've never had a problem with the UpdateSite stuff.  I always delete everything so it's clean.  Import the plugin and then do Application - Install in designer.  Always seems to work.

You might want to take this one to StackOverFlow - lot of plugin experts over there.  that's all I can think of at the moment.