FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.



Oct 24, 2013, 7:17 PM
1 Posts

PDF converter Hangs XWorks Application

  • Category: XWork Server
  • Platform: Windows
  • Release: 9.0
  • Role: Administrator
  • Tags:
  • Replies: 1

A custom app is using IBM Xworks to run a pgm to handle Electronic Forms. We produce PDF files using a converter (omniformat) from PDF995 to convert a HTML page into a PDF. Works perfect on 2003 and on 2008, but in Windows 2012 if I run the command from a DOS window - works fine, but when it's called from within Domino Script - it just hangs and never produces the PDF.  It's called via simple shell call, runs the OmniFormat program and creates the PDF from a URL into a specific directory so we can send it out.


Odd thing is, I can launch Xworks as a desktop program and it works, but when I run XWorks as windows service I have the problem.  My answer was build the new server under 2008R2 but they wanted 2012.  Right now we are running it as a desktop app, but that is less than optimum. 


I thinking this has some interactive security problem with 2012 - I know that part of the OS is really tightened up. I am looking for some guidance,ideas,suggestions. 

Oct 28, 2013, 3:43 AM
170 Posts
Windows 2012

Any newer version of Windows doesn't allow you to run anything with a command prompt.

I would create another program that the server calls and this program handles the call to you first program and suppress the command prompt or redirect it
to another location.

 

/Fredrik

www.xpagedeveloper.com


FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.