Jul 11, 2011 5:56 PM
64 Posts

$$OpenDominoDocument.xsp gives a 404 errror....

  • Category: Server Side JavaScript
  • Platform: Windows
  • Release: 8.5.1
  • Role: Developer
  • Tags: Viewpanel links
  • Replies: 2
- I'm actually using a viewpanel control, which is nearly a first for me, and naturally it's not working correctly.  I have XPages that have no forms associated with them; they simply have a "formName" on the datasource so when it commits the data, they may be included/filtered/whatever in Views by Form name like any other document.  This XPage saves data just fine, and if I manually append ?doucmentId=<unid>&action=editDocument, I get the saved document in edit mode just like a should.
 
- But the viewpanel links, which use the form $$OpenDominoDocument.xsp&documentId=<unid>&action=editDocument always fail with a 404 "Item not found" error, for both read and edit mode.  Typical for me that automagic doesn't work.  That's why I spend so much time trying not to use it.  (wry grin)

- Any hints why this happens?  Hopefully I'm missing some magic checkbox somewhere and that will be that, but the 'net has next to nothing what-so-ever relating to $$OpenDominoDocument.xsp at all.
 
Thanks for your time...
Jul 12, 2011 1:27 AM
129 Posts
Re: $$OpenDominoDocument.xsp gives a 404 errror....
Normally this is due to no default XPage to open/edit the documents in have been set in the view panel control/the form hasn't been set to open its document in a specific XPage.
 
One of the two have to be set for links to work. 
Jul 12, 2011 12:45 PM
64 Posts
I'll give this a whirl...
- Right now I'm just using a datatable because it was simpler.  (grin)  Thanks!...