Sep 10, 2015, 3:12 AM
177 Posts

XPages - server security

  • Category: Other
  • Platform: All
  • Release: 9.0.1
  • Role: Administrator,Developer
  • Tags: security
  • Replies: 1

I have an XPage on server A that should work with data residing on server B.

However I get a 403 error. (I have access to the data database - checked).

I am not listed in the following group on Server B:

- Sign agents or XPages to run on behalf of the invoker:

If I create an XPage on server A and drag in a view control and point to a view on server B I get the data.

I am also not listed in the following group on server B:

- Sign script libraries to run on behalf of someone else:

In my xpages I invoke managed beans / java classes to collect the data.

Could this second security property be due to the 403 message?

Sep 10, 2015, 1:59 PM
453 Posts
what I have found

XPages seems to like everything signed by the same ID, and that ID has to be pretty much killer. My experience (I am not an Admin) has been the signing ID needs all rights to everything. I recommend to my clients that they should generally sign the DB with the serverID. Then have the group LoacalDomainServers have all rights on all servers.

I have had instances where most of a DB was signed by the server, but some were signed by me (even though I'm part of a group Notes_Admin) that has all rights and got an error. If I sign the DB entirely with my ID or entirely by the serverID it works. Can be very frustrating until you get that figured out. I have found that a 403 error is always an issue of signing.