Jan 21, 2015 6:12 PM
1 Posts

Install Problem

  • Category: Extension Library
  • Platform: All
  • Release: 8.5.3
  • Role: Administrator,Developer
  • Tags:
  • Replies: 1

Hi,

I have Domino 8.5.3 FP6 after upgrade from version 8.0.1. I'm trying to install XPages Extension Library and unfortunately without success. I carry out the installation instructions below:

http://www-10.lotus.com/ldd/ddwiki.nsf/xpDocViewer.xsp?lookupName=Domino+Designer+XPages+Extension+Library#action=openDocument&res_title=Installing_the_OpenNTF_update_site_on_the_Domino_server_ddxl853&content=pdcontent

After the command: "tell http osgi ss com.ibm.xsp.extlib" getting

http://postimg.org/image/x5dx5btj3/

This is not consistent with the outcome of the instruction. Is it ok? Because when open this example in Designer:

http://www-10.lotus.com/ldd/ddwiki.nsf/xpDocViewer.xsp?lookupName=Domino+Designer+XPages+Extension+Library#action=openDocument&res_title=Installing_and_running_the_demo_application_ddxl853&content=pdcontent

I'm getting 61 errors and 1 warning and when I'm trying view example app "Admin_Home" in Notes I'm getting 404 Error....

any advice please,

Look

 

 

 

 

Jan 22, 2015 8:56 AM
588 Posts
hmm

All I can suggest is to make sure you're installing the correct Extension library.  Looks like the one you want is from April 2013.  That's the last one for the 8.5.3 servers.  All the newer stuff needs 9.x  I assume you have the update pack on your 8.5.3 server?  I think that's seperate from the fixpacks.  I'm not sure though.  But there was an actual update pack to add the Ext. Library I thought and the latest OpenNTF 8.5.3 builds might be assuming that you have that installed.

I guess I should point out that it would be so much better to get to the 9.x severs for XPages development.  The Core comes with Ext. Library built in and there's now been 13 updates to that piece on OpenNTF. 

The last Ext. Library update for 8.5.3 is almost 2 years old already...  that seems so ancient.   It seems odd to me that you upgraded from 8.0.1 to 8.5.3 and didn't go to something in the 9.x.

I'm sure you didn't make that decision or maybe even have that control but in today's world of security updates and users being able to update their phone and table OS's whenever they want...  it's getting to be more and more of a problem not to have current servers.  The recent iOS8 mess is proof of that.  So just something to consider.

 

Good luck