FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.



Dec 1, 2012, 11:43 AM
135 Posts
topic has been resolvedResolved

Server 8.5.3FP2 -> FP3 broke Web Service Provider

  • Category: Other
  • Platform: Windows
  • Release: 8.5.3
  • Role:
  • Tags: Web Service
  • Replies: 2
Sorry, no time to write detailed description because I need to get this working. This upgrade broke my Domino Web Service Provider. Maybe more info later. Please post here if you know more about this and possible fixes.
 
Provider gives no error, client/consumer (pure Java solution) gives this:
 
HTTP JVM: javax.xml.ws.soap.SOAPFaultException
HTTP JVM: java.lang.reflect.InvocationTargetException
HTTP JVM: javax.xml.ws.soap.SOAPFaultException: java.lang.reflect.InvocationTargetException
HTTP JVM: at com.sun.xml.internal.ws.fault.SOAP11Fault.getProtocolException(SOAP11Fault.java:190)
HTTP JVM: at com.sun.xml.internal.ws.fault.SOAPFaultBuilder.createException(SOAPFaultBuilder.java:123)
HTTP JVM: at com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:120)
HTTP JVM: at com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:90)
HTTP JVM: at com.sun.xml.internal.ws.client.sei.SEIStub.invoke(SEIStub.java:119) 
 
It does not work with Domino Web Service Consumer either. 
 
Looks like it's time to move to pure XPage/Java solution also at the endpoint/provider. Not sure how easy or difficult it will be. For short term downgrade seems the best option.
 

Dec 2, 2012, 6:56 AM
6 Posts
Re: Server 8.5.3FP2 -> FP3 broke Web Service Provider
We have couple of Java web service providers and all of them work after fp2 to fp3 upgrade. But we did not recompile those web service providers since the upgrade.
 
EDIT: some were recompiled in 8.5.2FP2 designer -> still working
 
EDIT2: still working even after recompiling in 8.5.3FP3 designer
 
server is 8.5.3FP3 on linux
Dec 2, 2012, 7:46 AM
135 Posts
Re: Server 8.5.3FP2 -> FP3 broke Web Service Provider
Good to hear it works for you. In my case the Provider is written in Java and it constructs another Java class in the first line. The provider is started but it fails without error when trying to construct the other Java class.
 
EDIT 
 
Looks like installation removed all added jars from jvm/ext which is probably causing this problem. I would have expected an error message. It failed when trying to construct abject from class which uses these jars, before trying to use them.
 
Sorry this thread is not related to XPages at all. 
 
- Panu 


FORUM PLAN UPDATE
Date revision: This forum will remain open to new posts and responses until December 1, 2018. (After that date, you will still be able to view and search the forum.) Also, we're taking a second look at the best place to host future conversation. For now, keep using this forum, and stay tuned for more news.