May 3, 2017, 9:09 AM
68 Posts

weird error when opening a document using another form

  • Category: Debugging
  • Platform: Windows
  • Release: 8.5.3
  • Role: Developer
  • Tags:
  • Replies: 1

I have an xPages application that works perfectly in development, but the production copy has an issue (these are both on the same server).  There is a view of response documents, and the form is set to open a specific xPage.  Using the production database, clicking on any link in the view control gives me the exception:  "Could not open the document.  NotesException: Search"  In the stack trace, a similar error: NotesException: Search

I thought this may be a problem with the search custom control, but that wasn't it (I removed it and got the same result).  The database is full-text indexed.

I tried to replace the design, and will keep trying, but even with Manager access, the design replace doesn't always "take".  I've also had the admins run Fixup on the database.

Ever seen this before?

May 18, 2017, 9:14 AM
14 Posts
I've seen something like it, but not it.

Compiling Java agents, sometimes the design-replace of the agent didn't result in a recompile. Normally backing off the "automatic" recompile, cleaning, bumping(edit/minor change/save) the design element, cleaning, and a build-all forced a recompile. After that -- didn't happen.

Oh, and all the databases without exception were built under ND7 or earlier.